Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. The 2022.2 beta is now available for testing. To find out what's new, have a look at our 2022.2 feature highlights.
    Dismiss Notice
  3. We are updating our Terms of Service for all Unity subscription plans, effective October 13, 2022, to create a more streamlined, user-friendly set of terms. Please review them here: unity.com/legal/terms-of-service.
    Dismiss Notice
  4. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice
  5. Join us on Thursday, September 29, for a day with Unity's SRP teams here on the forum or on Reddit, and discuss topics around URP, HDRP, and the Scriptable Render Pipeline in general.
    Dismiss Notice
Dismiss Notice
Submit bug reports tagged with #Beta2022Win_Unity when you encounter unknown issues while testing the 2022.2 betas for a chance to win a year of Unity Pro. For more information, have a look at our Beta Sweepstakes Announcement.

Mobile Edit > Project Settings > Editor > Joystick Source (Remote || Local) --- Local Keyboard Issue

Discussion in '5.4 Beta' started by Fronne, Jul 12, 2016.

  1. Fronne

    Fronne

    Joined:
    Sep 25, 2014
    Posts:
    110
    Joystic Source.jpg

    In Unity 5.4.0.b24 my (local) Keyboard didn't work anymore, in b23 and before everything works fine...

    You might think why do you need a Keyboard for mobile Development but using a Keyboard can save you so much time in the Development Process. I use the Keyboard to trigger some Events like swapping some GameObjects, changing the speed, even a window pop-up. I was pleased when 5.4.0.b25 came out because I tought everything should work fine again but it didn't...

    After a few hours trying to find documentation for this Issue and looking for a new switch, I found a new setting in the Editor Settings named Joystick Source, the default setting was Remote. When I switched this setting to Local my Keyboard was working like a charme again. In the b24 documentation there is (at the moment) no documentation for this setting.
    Perhaps it's a good idea to introduce a new Keyboard setting for Unity Remote named "Use Keyboard" with an option for None || Local with the default setting Local to solve this issue.

    I created this thread because other Developers might have the same Issue...

    Cheers,
    Franco Palmieri - Fronne
     
    Last edited: Jul 12, 2016
  2. inkredibl

    inkredibl

    Unity Technologies

    Joined:
    Nov 11, 2015
    Posts:
    21
    Hey there,
    Could you please describe your setup in a bit more detail? What platform you are using Unity on, what platform runs UnityRemote, what kind of connection do you use for your keyboard and what kind of keyboard it is. Thanks for letting us know!
     
  3. Fronne

    Fronne

    Joined:
    Sep 25, 2014
    Posts:
    110
    Hi,

    Just to be clear, the Issue appears only at runtime with a remote plugged in, the Keyboard works perfect without the remote plugged in. The remote device is an iPhone 5S, my Keyboard is a Microsoft Wireless Keyboard 2000, Win 10 Pro,
    i7-3770 CPU @ 3.40GHz, 12 GB memory, iOS and Android Components installed, Unity Plus...

    Cheers!
     
unityunity