Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

EasyRoads3D v3 - the upcoming new road system

Discussion in 'Works In Progress' started by raoul, Feb 19, 2014.

  1. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447

    Hi Marco,

    Please ignore that specific folder with prefabs, it is outdated and not used anymore. If you do want to use them you could probably create new custom prefabs out of them.

    Thanks,
    Raoul
     
  2. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    How does saving the scene not save updated marker positions? I have never heard of issues with that and me myself have been literally doing that for the past two years every day :)

    Coud you expand on that? In which particular case does saving a scene not save new marker positions or other changes?

    Thanks,
    Raoul
     
  3. Marco-Sperling

    Marco-Sperling

    Joined:
    Mar 5, 2012
    Posts:
    598
    In our case it happened when utilizing Unity's multi scene editing. Create a scene that only holds the road network. Add several scenes to that master scene that contain a terrain each.
    Now edit the road network as you wish. You will notice that dragging markers around does not trigger a scene change state (normally indicated by an asterisk * next to the name of your scene in the hierarchy). Force saving the scene now does nothing (right click, save all). Absolutely nothing. The scene remains unedited therefore Unity does nothing.

    Edit:
    I think I narrowed it down to the "Save All" functionality of the Unity Editor. It seems like this little bugger does not do what it should do.
    Saving the scene individually via "Save Scene" works though the asterisk issue persists when moving markers around or editing the road layout.
    Some of the actions that don't flag the scene as being changed are:
    Moving markers, inserting markers, deleting markers, dragging new roads out from existing connections.
    Hope this helps to find a solution.
    A temporary workaround for me is to not rely on "Save All" for now and to make sure I edited something else besides the road network (some dummy object I drag around in the scene).
     
    Last edited: Jun 29, 2016
  4. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447

    Thank you Marco,

    So this is multi scene editing related. I haven't played a lot with this yet. I will see how "Save" "Save All" behaves and what options we have related to all this.

    A quick look at https://docs.unity3d.com/Manual/MultiSceneEditing.html and untested, did you try setting your Road Network scene as the "Active Scene"? That page also indicates that "Save Scene" (Ctrl + S?) should target the selected scene.

    Other than that, everything related to markers is stored in ERModularRoad attached to the individual road objects. I cannot see how that would cause issues by itself.

    Raoul
     
  5. Marco-Sperling

    Marco-Sperling

    Joined:
    Mar 5, 2012
    Posts:
    598
    Yep, the road network scene is the active scene whenever we build something with it. I will try various combinations of saving when I get the time to test it some more.
     
  6. lunar211

    lunar211

    Joined:
    Jun 23, 2016
    Posts:
    4
    Well the game runs now, the error was because I installed the wrong version of windows module:oops::p (I had unity 5.3.5 installed and I was trying to use the windows module of 5.4.5). I just had to update my version of unity and everything is running smoothly:cool::cool::cool::):):)
     
    raoul likes this.
  7. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    The next update will include a fix for this. Meanwhile, a quick Inspector toolbar tab click should also trigger the scene change indicated by * after which "Save" or Ctrl+S should work fine.

    Thanks,
    Raoul
     
    Last edited: Jun 30, 2016
    Marco-Sperling likes this.
  8. Marco-Sperling

    Marco-Sperling

    Joined:
    Mar 5, 2012
    Posts:
    598
    Is there a way to adjust the splatmap settings (active/inactive, splat0, splat1 ... splatN) for any given road type globally after the roads have been placed? Or is this another case of "you need to do this in advance"? Done is done?
     
  9. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Marco,

    You may want to create a road that is almost the same as a specific existing road type and therefor use that road type to create it but change some of the settings afterwards.

    This makes auto updating scene instances of a specific road type after changes to that road type in General Settings tricky.

    To improve this, a road type dropdown can be added to the road settings where you can unlink the currently associated road type. Additionally an "Update Scene Instances" button can be added in General Settings > Road Types and in Scene Settings an "Auto Update Scene Instances after Road Type Changes" option can be added. Will that work?

    And, as mentioned before, "the other case of..." is possible in the next update which will soon be available.

    Thanks,
    Raoul
     
  10. Marco-Sperling

    Marco-Sperling

    Joined:
    Mar 5, 2012
    Posts:
    598
    That would be great and very helpful as we need to develop a look while working on the living object. Workflows that require fixed setups in advance are time consuming to deal with. So any kind of "Update Scene Instances" would be a huge step forward for us. :)
     
  11. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Ok I will add those things to the list. :)

    Thanks,
    Raoul
     
  12. MoribitoMT

    MoribitoMT

    Joined:
    Jun 1, 2013
    Posts:
    301
  13. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi MoribitoMT,

    This is most likely a shader issue, that is why I mentioned the offsets in the shader. What is it exactly that you tried? And is this indeed resolved when using the original Unity 5 Standard shader?

    Thanks,
    Raoul
     
  14. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Guys,

    It seems the old forum is back on without the latest post added in the "new" forum. Below is a copy one of the posts that were added in the "other" thread:

    Beta 7.7.3 is now available on our website

    The asset store update is availlable as well meanwhile.

    Side objects can now be activated/deasctivated for multiple selected markers simultaneously. Furthermore this update includes fixes for issues due to changes in Unity 5.3 and Unity 5.4.

    As always, please backup your project first before importing the update.

    Thanks,

    Raoul
     
  15. Zireael07

    Zireael07

    Joined:
    Apr 27, 2016
    Posts:
    47
    @raoul, the site says to contact you for access to beta. However the form also says contacting you on these forums would suffice. Is it true? I'd rather not spread the contact information I already submitted as part of registering the 7.7.1. beta...
     
  16. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Zireael07,

    You can use the same link as before to download updates from our website. Contacting us is more for those who do not have this download link yet.

    beta 7.7.3 has been approved by the asset store team and is now also available directly from the asset store as a separate unity package. You can see that at the top in the Package Contents section, https://www.assetstore.unity3d.com/en/#!/content/469.

    Thanks,
    Raoul
     
    Zireael07 likes this.
  17. SIP-Servo

    SIP-Servo

    Joined:
    Jul 21, 2014
    Posts:
    27
    trying to create a road on my terrain but I am getting walls on both sides of the road when trying to place on terrain, the terrains are Terrain composer terrain tiles..

    trying to raise the road marker I have to raise the road high above the terrain for the walls to vanish, but on compile the road is on tall bank.. any suggestions on way to fix this so I can have road flat to the terrain?
     

    Attached Files:

  18. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi SIP-Sirvo,

    Looking at the screenshot it seems you are using v2, is that right?

    Terrain Composer indeed usually generates multiple terrain tiles, in v2 you have to actívate "Multiple Terrains" in the General Settings tab and select the active terrain (the terrain you are working on) from the dropdown further below or by Ctrl + Alt + Click on the active terrain. Does that solve the issue?

    In v3, this thread :), multiple terrains is supported out of the box, no need to select the active terrain or enable multiple terrains.

    Thanks,
    Raoul
     
  19. SIP-Servo

    SIP-Servo

    Joined:
    Jul 21, 2014
    Posts:
    27
    got it working installed the newest version from asset store download :)
     
    raoul likes this.
  20. Fr2

    Fr2

    Joined:
    Jan 19, 2013
    Posts:
    28
    Hi Raoul,

    I'm trying the latest version of the V3 package (v2.5.9.1, 7.7.3), but for some reason the terrain flattening functionality doesn't seem to be working for me. When I click "Build Terrains(s)" after adding my markers I can see that a background process has started - in the bottom right corner of Unity I can see (e.g.) "5/1 clustering | 2 jobs" which completes without error. But for some reason the terrain isn't flattening. Clicking "Finalize" doesn't flatter the terrain either.

    To test v3 I've created a new scene with Unity's terrain tool, and have been sure not to import any of the V2 functionality apart from the v3 unity package, which I've then installed. This must be user error on my part as I can't see anyone else reporting the same problem!

    Thanks.

    Edit: Figured it out. In Settings > Road Types I selected "Terrain Deformation" and then re-added the road, and deformation appears. I think someone mentioned this earlier in this thread, but I couldn't find the "Terrain Deformation" option at first.
     
    Last edited: Jul 15, 2016
  21. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Fr2,

    Yes, exactly :)

    In the demo scene this setting should be correct for all available road types. But I belief there are some project road types not part of the demo scene for which "Terrain Deformation" is still switched off by default. I will check that.

    Also, the same "Terrain Deformation" option is available in the Inspector for roads already part of the scene.

    Thanks,
    Raoul
     
  22. Fr2

    Fr2

    Joined:
    Jan 19, 2013
    Posts:
    28
    Hi Raoul,

    I've been trying to work out how to create an effect like this example you posted earlier in the thread:

    road_cliff1.jpg
    I've taken a look at your latest youtube tutorials, but couldn't find an example. Is there something I can use a starting point?

    Thanks,

    Fred.
     
  23. MramidK1

    MramidK1

    Joined:
    Jul 16, 2016
    Posts:
    6
    Hi!
    Sorry my english!


    As used in conjunction Map-ity and Easy Road?


    Asbstraktny example plz code. For the construction of roads .
     
  24. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Fred,

    Examples of this will be part of the new demo project.

    This road in the screenshot uses 3 side objects:

    1. On the inner side a Shape type of side object simulating terrain

    2. On the outer side a Shape type of side object for the wall

    3. A Mesh type of side object for the top bricks

    Instead of the outer wall you can also use a similar side object, simulating terrain, on the outer side of the road.

    The wall is a simple shape:

    1. Create a new side object > select “Shape Object” as the Object Type

    2. Click “Open Shape Editor Window”

    3. You can add nodes by double clicking on the stage. Start by adding a node near (0,0) add a node a little bit further to the right (width of the wall), to control the normals you can add an addition node slightly more to the right, add the last node vertically downwards. This is the wall shape. Click Apply to save and close the window.

    4. In the Side Object Manager select “Relative to the Right Side of the Road” below X Position. This will attach the side object to the right side of the road.

    Select the road and activate this new side object. Only activate it for the required markers.

    The mesh terrain on the inner side also is a shape side object:

    1. Create a new side object > select “Shape Object” as the Object Type

    2. Click “Open Shape Editor Window”

    3. In this case we snap the outer nodes at the top to the terrain (Snap to Terrain checkbox)

    4. In the Side Object Manager select “Relative to the Left Side of the Road” below X Position. This will attach the side object to the left side of the road.

    The next step is to control the terrain deformation for those markers. You can do that by choosing one of the other options for “Right Indent Alignment” instead of “Align with the road”, the same for the left indents. You will see the white surfaces adjust.

    Let me know if you have further questions.

    Thanks,
    Raoul
     
  25. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi MramidK1,

    The runtime demo scene includes an example of how you can create a road through code by passing an array of Vector3 control points, in short:

    Code (csharp):
    1. ERRoadNetwork roadNetwork = new ERRoadNetwork();
    2. ERRoad road = roadnetwork.CreateRoad(string roadName, Vector3[] markers)
    V3 also includes built-in options to import road data (OSM and KML is supported).

    Thanks,
    Raoul
     
  26. Fr2

    Fr2

    Joined:
    Jan 19, 2013
    Posts:
    28
    Hi Raoul,

    I've managed to get a good result with your suggestions for roads on steep terrain with the outer wall:

    road-wall.jpg
    The only problem I'm having is with the inner wall. If I set the markers "Left Indent Alignment" to "Align with the terrain", and also enable my inner wall, I get this:

    inner-wall2.jpg

    It seems that the inner wall isn't cutting into the terrain mesh. Here's my settings for the inner wall:

    inner-wall-settings.jpg

    And the shape editor for the inner wall looks like this:
    shape-editor-inner-wall.jpg

    I wasn't sure what kind of shape the inner wall should take, so I went for something very tall. The two top nodes have "snap to terrain" checked.

    Any ideas what I'm doing wrong with the inner wall?

    Thanks,

    Fred.
     
  27. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Fred,

    There are two things here:

    1. What type of Wall do you want to create? You set the top two markers to snap to the original terrain height at that position. That is what happens in the screenshot.

    2. How should the terrain deformation be handled? The screenshots do not clearly show the terrain deformation settings for the markers in that area. When you switch on one of the different options to show the terrain deformation surfaces in General Settings > Scene Settings, you will get a clear view how the terrain will be flattened.

    Thanks,
    Raoul

    Edit:

    On the left side, where the terrain is higher then the road, you do not want to change "Left Indent Alignment" to "Align with the terrain". This will indeed result in the terrain breaking through the road.

    On the left side the terrain is above the road, changing the terrain deformation settings to match the terrain height at the indent position point (which is above the road) will result in the terrain breaking through the road. The only thing to do is create a shape that will build a terrain mesh overlay that will smoothly follow the road.
     
    Last edited: Jul 18, 2016
  28. BigYetti

    BigYetti

    Joined:
    Apr 11, 2015
    Posts:
    26
    Hello,
    How can I get a reference in code to a road network created from the Create menu? I see from the demo scene how to work with road networks and roads all created in code. Did that just to see, and it works. But I want to make the road from the scene view, then do other things from code. Way easier to generate a known road layout from the scene view.

    So I tried using (C#):

    ERRoadNetwork roadNetwork = GameObject.Find("Road Network") as ERRoadNetwork;

    But Unity throws:

    Assets/Scripts/PhysicsEngine.cs(98,63): error CS0039: Cannot convert type `UnityEngine.GameObject' to `EasyRoads3Dv3.ERRoadNetwork' via a built-in conversion


    Once I can get a handle to the road network, I think the rest is not so difficult. Just can't seem to find how to do get a reference to an existing road network.

    Unity V5.3.5f1
    EasyRoads3D v3 Beta 7.7.2



    Thanks in advance....
     
    Last edited: Jul 18, 2016
  29. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi BigYetti,

    That will indeed not work.

    Code (csharp):
    1. ERRoadNetwork roadNetwork = new ERRoadNetwork();
    This will create a new road network if no road network exists yet in the scene. But it will also create a reference to an already existing road network in the scene.

    Thanks,
    Raoul
     
  30. BigYetti

    BigYetti

    Joined:
    Apr 11, 2015
    Posts:
    26
    Yup, it works as you stated.
    Thanks!
     
    raoul likes this.
  31. TheVoidPT

    TheVoidPT

    Joined:
    May 27, 2016
    Posts:
    4
    Hello Raoul,

    Edit: Don't you hate when you find a solution 5 minutes after I post a question... I'll post my the code here once I'm done.


    I've been using this asset and I'm very pleased with it. It works great.

    I've been trying the runtime API. Unfortunately I don't understand how to instantiate crossings and connect roads to them.
    Could you please post an example of how it is done? Thanks.

    Btw I have the pro version.


    Kind Regards
    Miguel Pereira
     
    Last edited: Jul 19, 2016
  32. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Miguel,

    Glad to hear you like it!

    It seems you already figured out how to do this. Just in case:

    Code (csharp):
    1. // get all available connection prefabs in the resources folder
    2. ERConnection[]  connections = roadNetwork.LoadConnections();
    3.  
    4. // or
    5. ERConnection  connection = GetSourceConnectionByName(string name);
    6.  
    7. // Instantiate
    8. ERConnection  newConnection = roadNetwork.InstantiateConnection(ERConnection sourceConnection, string name, Vector3 position, Vector3 rotation);
    9.  
    10. // attach the start of a road to connection
    11. road.ConnectToStart(ERConnection connectionObject, int connectionIndex);
    12.  
    13. // attach the end of a road to connection
    14. road.ConnectToEnd(ERConnection connectionObject, int connectionIndex);
    http://unityterraintools.com/EasyRoads3D/v3/html/scriptingAPI.html

    Thanks,
    Raoul
     
  33. Fr2

    Fr2

    Joined:
    Jan 19, 2013
    Posts:
    28
    Hi Raoul,

    I had a chance to experiment some more, and managed to create an inner wall OK:

    wall-inner3.jpg

    What I'd really like to work out is how to create the inner side effect that you have in the screenshot below. I can see that the inner side object appears to be right next to the road (red arrows):

    road_cliff1b.jpg

    If I remove the inner wall from a couple of markers with the left indent alignment set to "align with the road", I can see that there is a distance between the road and terrain (in red below):

    no-inner-wall2.jpg

    And so I couldn't work out what kind of side object could create the same effect.This is the bit I couldn't understand:

    Perhaps the best thing to do will be to wait until there's an example I can try?

    Thanks,

    Fred
     
    Last edited: Jul 20, 2016
    Himanshuchahar likes this.
  34. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Fred,

    Yes, because of the grid based nature of the unity terrain object it is fairly impossible to get a smooth terrain right next to the road.

    The inner side of the second screenshot works similar as how you created the wall. This is the setup used in that image:

    3 nodes at the bottom, one at (0,0) the road edge and two nodes slightly to the left.

    2 nodes halfway with "Snap To terrain" toggld on. This creates the effect of the area with the rock texture. The nodes will snap to the original terrain height. The terrain is later flattened in that area so it won't interfere with the generated surface mesh.

    1 node to the left at a little bit more then heightmapscale distance, the distance over which the terrain is leveled from the road height to the original terrain height.

    The reason for the 3 nodes at the start and 2 nodes in the middle is to create the short blend effect from gravel next to the road to rock and from rock to rock/grass midway.

    The texturing is done by assigning color info (red, green, blue) to each node in the Shape Editor Window, this color info is used in a custom shader. This shader was just experimental, I am working on proper Unity 5 shaders for this.

    Alternatively you could do something similar with your wall. Instead of having it go downwards on the outer side, do something like described above and have it snap to the terrain outwards and use terrain textures for that area.

    Thanks,

    Raoul
     
    Last edited: Jul 20, 2016
  35. MoribitoMT

    MoribitoMT

    Joined:
    Jun 1, 2013
    Posts:
    301
    Hi,

    I made a very simple dirt road and finalized it. However in my build to Android .apk file become huge, build reports shows that all other textures like railroad, roads, etc.. from easyroad was included in the build. None of this textures is being used in project

    Any idea ?
    Regards
     
  36. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi MoribitoMT,

    V3 has runtime functionality. This is the reason why currently all involved assets, (textures, crossing prefabs, etc) are located in the Resources folder which is included in your project build. Are these indeed the assets that you see in your final .apk?

    Can you try removing unused assets in this folder: /Assets/EasyRoads3D/Resources/

    If this is still experimental you probably want to do this test in a backup of the project.

    Thanks,
    Raoul
     
  37. MoribitoMT

    MoribitoMT

    Joined:
    Jun 1, 2013
    Posts:
    301
    I
    I will try that thanx.

    What I did was for quick fix make all unused assets texture compression size to 32, my apk become 42 mb from 49 mb instantly. I think it would be good for you to make a way around this problem, beacuse in mobile projects size really matters

    Thanks for your help
    Regards.
     
  38. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Yes, you are right, this does need optimization, that is also why only a few road types and custom prefabs are included at the moment as (provisional) examples.

    There is one more "big" beta update coming up with this type of optimizations like also Undo/Redo for Scene View and Scene View/Inspector related operations. I will see if I can add this as well.

    Thanks,
    Raoul
     
    MoribitoMT likes this.
  39. Marco-Sperling

    Marco-Sperling

    Joined:
    Mar 5, 2012
    Posts:
    598
    Hi raoul,

    is there a way to store a particular road network setup as a prefab of its own and reuse that setup in other places?
    Take this autobahn interchange for example:

    It should connect to the green markers and deform terrain correctly - sloping up to the bridge and pushing into the terrain at its lowest points (the 2x2-lane highway under the bridge).
    From my understanding of ER3D I cannot simply construct such a model in Maya/Max and create a custom prefab connection out of it since ER3D would not be able to tell what part should influence the terrain. Bridge or highway beneath and/or connections left and right to the bridge.
    Or can I?
     

    Attached Files:

  40. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Marco,

    Indeed custom prefabs based on your own meshes will flatten the terrain according the y position of the prefab in the scene taking the rotation into account.

    I think it will certainly be a nice feature to be able to create a new "Connection Prefab" from a combination of connections and roads so you can reuse it. That way you can split the interchange in your image in separate custom prefabs, rebuild it inside EasyRoads3D and create a new connection prefab out of it. Since all the separate elements are already connected only the outer connections will be active after adding it to the scene.

    Thanks,
    Raoul
     
  41. AlbertoMastretta

    AlbertoMastretta

    Joined:
    Jan 1, 2015
    Posts:
    69
    Hi Raoul.

    I'm having a problem with the Box Colliders on my sideobjects. For many of the sideobjects I generate with Procedural Mesh Objects, the box colliders added to them have 0 scale in both X and Y. I end up with just a line that has no volume. I Haven't seen any problems in my setup. For example, I have two procedural objects that are identical in mesh, but different in color due to their UVs. One sideobject creates box colliders with proper volume and placement, and the other one creates them with 0 volume. Its just 0, 0, 2. They do have width. their placement is also 0, 0, 0.

    Any ideas on how to solve this? I could co and modify the box colliders manually, but it ends up being a very slow process and any time they get re-created or replaced, I have to do it again.
     
  42. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Alberto,

    Were those side objects that are working created in a previous build?

    Because there is an issue with this in the current build. This is fixed for the next build. The bounds of the prefab, used to generate the boxcolliders, were not correctly stored.

    Thanks,
    Raoul
     
  43. AlbertoMastretta

    AlbertoMastretta

    Joined:
    Jan 1, 2015
    Posts:
    69
    Thanks Raoul. I believe they were created in a previous build. I'll wait for the fix then, I can manually resize them for now. Thanks for the quick reply, as always.

    Cheers!
     
  44. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Alberto,

    Doing that manually sounds like a lot of work or is this only needed for a small area? Existing scene instances of that side object can be updated in the new beta which will hopefully be available by the end of next week. So you can continue building these side objects.

    Thanks,
    Raoul

    .
     
  45. Fr2

    Fr2

    Joined:
    Jan 19, 2013
    Posts:
    28
    Hi Raoul,

    I've had another try at creating the inner side object, and in the Shape Editor Window the nodes look like this:

    shape points 1.png

    But the effect I get looks like this:


    road with side object.jpg

    It seems that the middle two nodes don't seem to be snapping to the original terrain height, and I was wondering if there is a setting I'm missing. Here are my settings for the inner wall:

    inner wall config.jpg

    I wasn't sure if "Snap to Terrain" and "Terrain Alignment" were correct - I tried experimenting with different values but still couldn't get the right effect.

    Thanks,

    Fred.
     
  46. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447

    Hi Fred,

    It seems the two upper node now snap to the terrain at the lower node.

    Did you perhaps actívate this sideobject in Build Mode with the terrain already flattened matching the road?

    Can you show a screenshot of this side object in Edit Mode with the original terrain and the side object clearly visible?

    A simple way to test the behaviour of the node snapping to the terrain is to lay out a short road on a reasonably flat terrain.

    You probably also want to position the 2 markers in the middle halfway a little bit more away from each other on the x-axis. Right now they share almost the same x value which means they will snap to about the same terrain position which will minimize the blend effect.

    Thanks,
    Raoul
     
  47. Fr2

    Fr2

    Joined:
    Jan 19, 2013
    Posts:
    28
    Hi Raoul,

    Here's a screenshot of the road in Edit Mode:

    terrain-road-edit-mode.jpg

    Before making any changes to the road or side objects, I always click "Back to Edit Mode", so yes I think so.

    I tried positioning the middle nodes further to the left on the X-axis, but that didn't seem to help.

    Thanks,

    Fred.
     
  48. sstrong

    sstrong

    Joined:
    Oct 16, 2013
    Posts:
    1,653
    We've been working on the ER3 and LB integration. Here is a screenshot using the WeatherFX to modify the road texture to simulate a wet road. The amount of water on the road is controlled dynamically in code.

    LB WeatherFX_ER3b.png
     
    raoul likes this.
  49. camel82106

    camel82106

    Joined:
    Jul 2, 2013
    Posts:
    304
    Hi Raoul,
    getting back after some time with v3 and I'm really happy to see that crossings are now runtime API. Good work!

    I'm not sure if you have seen new AQUAS river feature. It's looking very nice:


    It supports rectangular plane. So now if I will create river mesh with Easyroads I have problem with UV tiling. You can read more in this Chris forum post that is explaining it:
    http://forum.unity3d.com/threads/up...le-vr-web-desktop.378519/page-11#post-2722140

    Basically to make Easyroads UV tiling compatible with AQUAS river feature. I would need to assign UV coordinates based on terrain position of river mesh. I suppose that it's relative easy thing to do in Easyroads. Wouldn't it be superb to support integration of Easyroads with AQUAS? ;)

    Best regards
    Peter
     
  50. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    5,447
    Hi Fred,

    Yes, it does look as it should in Edit Mode. I just did a quick test and indeed it looks like currently the node snapping is also active in Build Mode which should not be the case. I will fix that.

    Thanks,
    Raoul
     
unityunity