Search Unity

  1. We've closed the job boards. If you're looking for work, or looking to hire check out Unity Connect. You can see more information here.
    Dismiss Notice
  2. We're running great holiday deals on subscriptions, swag and Asset Store packages! Take a peek at this blog for more information!
    Dismiss Notice
  3. Check out our Unite Austin 2017 YouTube playlist to catch up on what you missed. More videos coming soon.
    Dismiss Notice
  4. Unity 2017.2 is now released.
    Dismiss Notice
  5. The Unity Gear Store is here to help you look great at your next meetup, user group or conference. With all new Unity apparel, stickers and more!
    Dismiss Notice
  6. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  8. Unity 2017.3 beta is now available for download.
    Dismiss Notice

Dynamic Batching not working and empty scene(only camera) has a draw call

Discussion in 'Editor & General Support' started by iaconic, Dec 30, 2012.

  1. iaconic

    iaconic

    Joined:
    Jul 26, 2011
    Posts:
    4
    Hello,

    I'm having an extremely weird issue with Unity right now. I have been trying to get Dynamic Batching to work for rotating coins with no luck. Something has gone wrong with my project, but only on my computer. In my project on my computer, each coin produces 2 draw calls, but on my friends they batch to 1 draw call all together. If I create an empty scene in my project, it will show 1 draw call - but not on my friends. I have made new projects that produce 0 draw calls in an empty scene. I have also downloaded a new copy of Unity 4 and installed, still no luck!

    The thing that really bothers me the most is that it works %100 the way intended on my friends computer, I gave him the project in a zip. But when I take the project back from him.. it stops working again!

    Has anyone else encountered this issue? Could there be some hidden data somewhere on my computer that I may need to delete? I Don't know what to do I am so confused and upset by this issue, please any information would be helpful

    Bit of info -
    Using Unity 4.0.0f7 Pro with iOS Pro
    2010 Macbook Pro 2.3GHz Intel Core i5
    Project contains NGui package
    Object is a coin, has 55 verts. Using Mobile/specular bump material. It is referenced from prefab. I have also tried a cube and it doesn't work.
    I have also confirmed that static batching DOES work.. but I don't want static coins