Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Dumb question? How do I update URP to 7.4.1?

Discussion in 'Universal Render Pipeline' started by Jamez0r, Jul 12, 2020.

  1. Jamez0r

    Jamez0r

    Joined:
    Jul 29, 2019
    Posts:
    205


    I've been using 7.1.8 for a while now and I would like to update to 7.4.1. I've looked everywhere on the Package Manager for a way to update.

    This page doesn't explain how, if there was some way other than Package Manager. Not to mention its kind of confusing what is going on with the versions there... what is URP version 8? Version 9?

    Thanks for any help, I'm sure I'm just missing something :confused:
     
  2. DebugLogError

    DebugLogError

    Joined:
    Jul 24, 2013
    Posts:
    57
    Open the manifest.json file in your project's Packages folder and manually edit the urp version.
     
  3. Refeas

    Refeas

    Joined:
    Nov 8, 2016
    Posts:
    192
    You are probably using an older version of Unity 2019.3, thus not being able to see the Update button in the Package Manager. Updating to 2019.4 LTS (basically patched up 19.3) should let you update via Package Manager.
     
  4. Jamez0r

    Jamez0r

    Joined:
    Jul 29, 2019
    Posts:
    205
    Thank you guys for the quick response!

    I updated to 2019.4.3f1 LTS. It still doesn't seem to have an option to update from within the Package Manager.



    I'll try updating the manifest.json, but I'm slightly concerned with doing that if the normal way is to update it through Package Manager :oops:

    Edit: This is strange because my Package Manager is still showing 7.1.7 (screenshot above), but in my manifest.json it is showing 7.3.1.
     
    Last edited: Jul 12, 2020
  5. MrPaparoz

    MrPaparoz

    Joined:
    Apr 14, 2018
    Posts:
    157
    Maybe remove URP entirely and re install?
     
  6. Jamez0r

    Jamez0r

    Joined:
    Jul 29, 2019
    Posts:
    205
    @MrPaparoz - thanks, that did seem to work. Here is what I did in detail:

    I didn't have any option to Update in Package Manager (above), so I went into my manifest.json (which already showed 7.3.1 for some reason...) and switched it to 7.4.1.

    I re-opened the project, and in the Package Manager it was still showing 7.1.7. The only option was to Remove 7.1.7, so I tried doing that. After I removed it, it now is showing a checkmark next to 7.4.1. When I select "verified 7.3.1" it has a button that says "Update to 7.3.1". Not sure if that part is normal or not.



    Also updated the Shader that was causing the purple-outlines in the screenshot above.

    After some testing, it looks to be good, I think! Thanks guys!