Search Unity

Does not work with Managed Stripping Level set to High

Discussion in 'New Input System' started by capkoh, Nov 30, 2019.

  1. capkoh

    capkoh

    Joined:
    Oct 1, 2016
    Posts:
    14
    Hi,

    I've decided to give a try to the new input system, but run into an issues that it does not work with Managed Stripping Level set to High. In the player I get the following exception:
    It happens in a Windows build using Unity 2018.4.3 and InputSystem 0.2.1. I also have keyboard added to the list of devices in the settings.

    In the build with low stripping level everything works fine, but since I'm using IL2CPP and targeting fast iterations, I would like to use high stripping level to get builds faster and smaller.

    Is there a way to make new input system work with High stripping level set?

    Thanks!
     
  2. Rene-Damm

    Rene-Damm

    Unity Technologies

    Joined:
    Sep 15, 2012
    Posts:
    905
    This is fixed in a newer version of the input system (we're now running our own project in the repo with stripping set to high). However, note that you will have to upgrade to 2019.1 in order to be able to get the fix. 2018 is no longer supported.
     
    capkoh likes this.
unityunity