Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Feature Request Disable volumetric cloud shadows in scene view

Discussion in 'High Definition Render Pipeline' started by Wolfos, Feb 5, 2022.

  1. Wolfos

    Wolfos

    Joined:
    Mar 17, 2011
    Posts:
    900
    Essentially what the title says. It gets annoying to edit a scene when half of it's covered in shadow.
     
  2. chap-unity

    chap-unity

    Unity Technologies

    Joined:
    Nov 4, 2019
    Posts:
    525
    Go to your volumetric clouds override (if there isn't, add one to one of your volume).
    Then, uncheck shadows at the bottom of the override.

    upload_2022-2-7_10-5-12.png
     
  3. Wolfos

    Wolfos

    Joined:
    Mar 17, 2011
    Posts:
    900
    I know but that requires remembering to check the box when you're done editing (which is undoubtedly going to lead to mistakes at build time). Would prefer to have some way to only enable them during runtime.
     
  4. chap-unity

    chap-unity

    Unity Technologies

    Joined:
    Nov 4, 2019
    Posts:
    525
    Best you can do right now, is disable on the scene view and override it to true on the game view. That way, no clouds, no shadows on the scene view, and clouds and shadows on the game view, but you can't just lose the shadows AFAIK.

    To disable it on scene view, go to the Project Settings > Graphics > HDRP Global Settings > Frame Settings (under lighting tab).

    To override it on the game view, sleect your camera and check custom camera frame settings and re-enable the clouds there.

    upload_2022-2-7_10-14-5.png
     
    Wolfos likes this.
  5. Wolfos

    Wolfos

    Joined:
    Mar 17, 2011
    Posts:
    900
    Oh I didn't think of that. That's clever, thanks.
     
    chap-unity likes this.