Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Dismiss Notice

Disable touch left swipe on windows 10 and standalone build

Discussion in 'Windows' started by SystemDevel, Apr 5, 2016.

  1. SystemDevel

    SystemDevel

    Joined:
    Oct 5, 2013
    Posts:
    36
    I'm doing a standalone app for use on windows 10 and touchscreen The problem is that when i'm On fullscreen at application if you make a left swipe gesture windows shows task view and you can close app/ change app....

    There is any way to disable this gestures by code or registry?

    Thansk a lot
     
  2. BrotenStudios

    BrotenStudios

    Joined:
    Feb 13, 2014
    Posts:
    155
    Ya I am working on unity Multi-display on Windows 10 with a HID Touch Screen Digitizer.

    And Windows has Edge Gestures when a Unity Game is running. Very annoying.

    Only thing I can think of is to place my HID TouchScreen into HID-Compatible mode and then maybe access the USB buffer directly in Unity. Since then windows does not know about the touch screen.

    Windows really should have had a Settings option to disable gestures.
     
  3. SystemDevel

    SystemDevel

    Joined:
    Oct 5, 2013
    Posts:
    36
    Hi @BrotenTechCorp

    If you accomplish this change please let me know how you do.

    My touchscreen is a PQlabs screen.
     
  4. BrotenStudios

    BrotenStudios

    Joined:
    Feb 13, 2014
    Posts:
    155
    Try:
    1. Open the Control Panel (icons view), and click/tap on the Mouse icon.
    2. In Mouse Properties, click/tap on the Device Settings tab, and click/tap on the Settings button.
    3. Check (enable) or uncheck (disable) the Enable Edge Swipes option, and click/tap on OK.
    4. Click/tap OK in Mouse Properties.
    Windows 10 does not always give this feature set.

    If that does not work try:
    http://winaero.com/comment.php?comment.news.103

    This is for Windows 8 but some say it works on Windows 10 as well. Disable the Apps Switcher, and Charms Bar.
     
  5. BrotenStudios

    BrotenStudios

    Joined:
    Feb 13, 2014
    Posts:
    155
  6. SunnyChow

    SunnyChow

    Joined:
    Jun 6, 2013
    Posts:
    360
    any other suggestions?
     
  7. shortnotion

    shortnotion

    Joined:
    May 20, 2015
    Posts:
    8
    +1!

    I'm also still looking to disable these "edge swipes" for a public facing fullscreen touchscreen application.
     
  8. karelamella

    karelamella

    Joined:
    Oct 28, 2018
    Posts:
    1
  9. SunnyChow

    SunnyChow

    Joined:
    Jun 6, 2013
    Posts:
    360
  10. Barikli

    Barikli

    Joined:
    Jul 24, 2017
    Posts:
    6
    i was using PQLabs and i could hide it by regedit.
    CURRENT_USER>Software>Policies>Microsoft>Windows>EdgeUI>Create 32 bit DWORD>rename "AllowEdgeSwipe">Restart pc.

    hope this helpfull.