Search Unity

Disable GI for 2D project

Discussion in '2018.1 Beta' started by Foriero, Mar 11, 2018.

  1. Foriero

    Foriero

    Joined:
    Jan 24, 2012
    Posts:
    464
    Hi, we have 2D project where we even dont use lighting at all. Our GI data and light maps are empty but still when I profile I see quite significant GI happenings. Is there a way to switch off GI completely?
     
  2. TehReason

    TehReason

    Joined:
    May 14, 2013
    Posts:
    53
    Did you disable all of the lightmap settings in the graphicssettings tab of your project?
     
  3. Foriero

    Foriero

    Joined:
    Jan 24, 2012
    Posts:
    464
    I don't know what else should I disable so that the GI Profiler is quite. Please see attachment.
     

    Attached Files:

  4. kemalakay

    kemalakay

    Unity Technologies

    Joined:
    Jul 12, 2016
    Posts:
    224
    Hey @Foriero !

    I don't know which version of Unity you're using but please go to Window > Lighting > Settings and disable both Realtime GI and Baked GI to turn off your GI systems.

    Thanks
     
  5. mh114

    mh114

    Joined:
    Nov 17, 2013
    Posts:
    280
    Yet, at least in 2017.1 and earlier, the Enlighten worker threads are still started even though we have a mobile game that doesn't use realtime GI at all, only baked lightmaps in some scenes. IMHO Unity should check the scenes in build and stop Enlighten threads from spawning if there is no need for them.