Search Unity

  1. Unity 2019.1 beta is now available.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We're looking for insight from anyone who has experience with game testing to help us better Unity. Take our survey here. If chosen to participate you'll be entered into a sweepstake to win an Amazon gift card.
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Unity 2018.3 is now released.
    Dismiss Notice
  6. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Disable FreeLook Axis Control during a blend from timeline

Discussion in 'Cinemachine' started by YuriyPopov, Nov 26, 2018.

  1. YuriyPopov

    YuriyPopov

    Joined:
    Sep 5, 2017
    Posts:
    69
    I'm using timeline to do cutscenes for my game and I want to blend from a cutscene to gameplay smoothly. Problem is that during the blend the axis control of the Free Look rig moves it and this can make the blend shaky. How can I disable the axis control of the freelook from timeline?
     
  2. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    2,056
    You need to set the FL axis input name to blank. You could try adding a script to the FL that does this if and only if there is a blend in progress (brain.IsBlending)
     
  3. YuriyPopov

    YuriyPopov

    Joined:
    Sep 5, 2017
    Posts:
    69
    Are there any events I can hook into? I cant seem to find them. Or do I just do it in a Update?
     
  4. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    2,056
    The brain does emit an CameraActivated event, and each vcam has an activation event.

    upload_2018-11-29_9-28-19.png

    upload_2018-11-29_9-28-42.png