Search Unity

  1. Megacity Metro Demo now available. Download now.
    Dismiss Notice

Question Diffuse Appears Pitch Black with Sky Lighting Only

Discussion in 'High Definition Render Pipeline' started by VoidGardens, Jan 14, 2024.

  1. VoidGardens

    VoidGardens

    Joined:
    Mar 2, 2018
    Posts:
    7
    Hi everyone,

    I'm encountering an issue where any diffuse (textures or simple colors) turns pitch black when there are no light sources other than the sky. Reflections and that fresnel thingy works as intendent.

    I've come across a couple of old forum threads with similar problems but no solutions:
    Initially, I thought I found a solution:
    "If you are using any kind of sky (hdri, gradient, etc.) and increase its exposure\multiplier\lux, you may find that only fresnel (rim) lighting remains, and your textures\colors turn black. To bring back textures and colors, use the 'Indirect Lighting Controller' and crank up the 'Indirect Diffuse Lighting Multiplier.' That should resolve the issue."

    But the next day when I launched my project, everything reverted to the black diffuse issue and old solution cease to work. I considered the possibility of a bug or that my cpu was penetrated with cosmic ray or something, but when I tested the HDRP sample project, the solution worked flawlessly.

    To compare, I've examined the volume settings in both my project and the HDRP sample project, here are components and settings of both projects:

    Visual Environment

    Gradient Sky

    Indirect Lighting Controller

    Exposure

    Environment Tab


    Here are the results:


    My scene with directional light:

    I would appreciate any suggestions on what settings to check or additional information to provide in order to resolve this issue. Sorry in advance if this it what described on first page of every HDRP manual, or if this is too obivious and that's why two threads above do not have any answers.

    • No baked lighting
    • No probes of any kind
    • Unity Version: 2022.1.10f1 (consistent across both projects)
    • HDRP Version: 13.1.8 (consistent across both projects)
     
  2. VoidGardens

    VoidGardens

    Joined:
    Mar 2, 2018
    Posts:
    7
    Found it!

    Navigate to Project Settings > Quality > HDRP > Lighting > Probe Volumes (Experimental) and untick 'Enable.' I'm not an expert, so I can't pinpoint exactly what's happening. Whether it's a bug or some specific option tweaking required for using Probe Volumes, I can't say. However, I can swear that I haven't touched this option lately, and everything seemed to be working fine. Anyway, I believe this might be the solution. Good luck!