Search Unity

Terrain Detail density issue after upgrading from 2018.2 to 2019.1

Discussion in 'World Building' started by mrtenda, May 22, 2019.

  1. mrtenda

    mrtenda

    Joined:
    Jun 6, 2017
    Posts:
    31
    terrain1.png
    When I painted new terrain details (grass) in 2018.2, the grass was very dense (which I liked). However, after upgrading to 2019.1, grass I paint with the same detail setup and the default brush is very sparse.

    The details I already painted in 2018.2 look exactly the same after upgrading to 2019.1, so I assume this is some difference between how the terrain editor paints details in 2019.1 and 2018.2. However, I can't find any option or brush setting that will allow me to paint dense grass like I did back in 2018.2.

    How I can get 2019.1 to let me paint dense details like the image on the left instead of the image on the right?
     
    Last edited: May 22, 2019
  2. chanfort

    chanfort

    Joined:
    Dec 15, 2013
    Posts:
    591
    Did you tried changing detail density in terrain settings?

    P.S. Just a bit off-topic, I somehow like the second image :) . It looks like the grass is fitting nicely with terrain texture there. Are you using some of Unity's assets or from asset store?
     
  3. mrtenda

    mrtenda

    Joined:
    Jun 6, 2017
    Posts:
    31
    My detail density is already at 0.8, and setting the detail density to 1 still doesn't make any new grass I paint as dense as it was in 2018.2

    Besides, the grass I painted back in 2018.2 still remains nice and dense after I upgraded my project to 2019.1. It's just the new grass I paint in 2019.1 that is all sparse, which leads me to believe it's not due to the detail density setting (which seems to affect all of the grass, old and new).

    As for the first image vs the second image, we want a "fluffy, thick" feeling for the grass, so the left version is what we want in this case. (And these are using custom assets.)
     
    Last edited: May 22, 2019
  4. alexr1221

    alexr1221

    Joined:
    Mar 5, 2016
    Posts:
    43
    In Unity 2019, the terrain is now 1000x1000 by default instead of 500x500, so there is 2x less grass density for the same resolution

    edit:
    To get more density you'll have to increase the detail resolution, which is 1024 by default. Just set 99999 and it will set you the max resolution
     
    mrtenda likes this.
  5. Woolf

    Woolf

    Joined:
    Dec 4, 2012
    Posts:
    22
    however, this will “kill” the old grass, which even after importing in 2019 looks better. Moreover, increasing the resolution to 2048 and higher significantly reduces the number of FPS in the final assembly (even if there will be as many parts).

    I guess that it’s not a matter of resolution, but of setting a brush. We just cannot set the grass with the right density. This is bug!

    this is really a problem for me. I am paralyzed the process of developing new gaming areas due to this annoying grass bug. Even increasing the resolution to 4096 does not give the old grass density as it was in v2017 or v2018
     
  6. FireChickenGames

    FireChickenGames

    Joined:
    Nov 26, 2018
    Posts:
    1
    Did you ever figure out a solution that doesn't require increasing the detail resolution?
     
unityunity