Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug Desktop resolution setting 'Exclusive Fullscreen' launches minimized to taskbar

Discussion in 'Editor & General Support' started by JumpWire, Jul 6, 2023.

  1. JumpWire

    JumpWire

    Joined:
    Dec 11, 2015
    Posts:
    18
    I have projects that I have been using for several years that run as fullscreen kiosks on the Windows desktop. All of a sudden when I publish with the 'Exclusive Fullscreen' setting the app shows the Unity logo and then minimizes to the toolbar. This is happening on multiple systems with both Unity 2020 and Unity 2022.

    Has anyone seen this? As an interim solution, I am using 'Fullscreen Window' but on one particular kiosk the Unity application is displaying but not as the frontmost app. Something about this PC is not letting the Unity app be active and in focus though it is visible, which causes it to stop running. I need exclusive fullscreen so that no other processes take over. Any ideas? This is turning out to be a real problem.

    I have updated the graphics drivers and as I said this is happening on multiple Windows 10 systems with two versions of Unity.
     
    Last edited: Jul 6, 2023
  2. JumpWire

    JumpWire

    Joined:
    Dec 11, 2015
    Posts:
    18
    Thanks. These installations have been running this app for years. One installation involves 8 PCs with 16 screens total. They all have the problem. Three different development computers with very different specs have shown the behavior.
     
  3. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    10,628
    This is your real issue. If something steals focus from exclusive fullscreen application, it will get minimized. That is expected behaviour. You need to figure out what is stealing the focus.
     
  4. JumpWire

    JumpWire

    Joined:
    Dec 11, 2015
    Posts:
    18
    That is one part of it. I am trying to replace that exe but it starts out minimized. I figured out that if I set it to 'run in background' that fixes the focus issue. It does not address the fact that all new projectors set to 'Exclusive Fullscreen' start minimized in both Unity 2020 and Unity 2022. This is real.
     
  5. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    10,628
    I suspect it doesn't fix the focus issue but merely makes it run when it's not focused. Exclusive fullscreen doesn't support that, though: it will force minimize if it's not focused.
     
  6. JumpWire

    JumpWire

    Joined:
    Dec 11, 2015
    Posts:
    18
    This behavior is new. I have been doing this a long time. Something changed. The fact that it is happening in Unity 2020 and 2022 makes me think something changed in the OS that Unity obviously has not realized yet. I first noticed it on a PC that was right out of the box. Then I tried to push it to an installation that has been running for 2 years. Then I recreated it on my development machine with a brand new 2022 project. Currently, the Exclusive Fullscreen option is a dead stick. I found a workaround so I will move on. Thanks.
     
  7. JumpWire

    JumpWire

    Joined:
    Dec 11, 2015
    Posts:
    18
    Also just to clear something up. In the past exclusive fullscreen has never minimized when it loses focus. That has never been true.
     
  8. Ryiah

    Ryiah

    Joined:
    Oct 11, 2012
    Posts:
    20,704
    Windows 10 automatically converts exclusive fullscreen to a borderless window.

    https://devblogs.microsoft.com/directx/demystifying-full-screen-optimizations/
     
    JumpWire likes this.
  9. JumpWire

    JumpWire

    Joined:
    Dec 11, 2015
    Posts:
    18
    This gives me a lot to investigate. Thanks. I suspected it was not Unity's fault. It is so strange that this just started happening. I think Microsoft is still 'optimizing' the FSE implementation.