Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Bug Deselecting Optimize Game Objects under import settings causes animations to break

Discussion in 'Animation' started by XJonOneX, Apr 16, 2023.

  1. XJonOneX

    XJonOneX

    Joined:
    Dec 19, 2017
    Posts:
    116
    I hope this is the right forum for my issue.

    When I deselect 'Optimize Game Objects' under the import settings for my model, the animations I have setup just flat out break. Once I reselect 'Optimize Game Objects' everything works the way it should.

    Here is a video showing my problem:


    I want to have all the sub meshes listed in a hierarchy, and deselecting 'Optimize Game Objects' does that. If there's another way to achieve this without messing with 'Optimize Game Objects' that'd be great. A solution to the issue at hand would be great also.

    Any and all help is appreciated! :)
     
  2. XJonOneX

    XJonOneX

    Joined:
    Dec 19, 2017
    Posts:
    116
    So I had my Animator component on the parent gameobject which has the model as a child. If I moved the Animator component to the model itself, animations played properly.
     
    tsukimi likes this.