Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Resolved Dependency on collections is very old in transport 1.3.4

Discussion in 'Unity Transport' started by Krooq, Jun 14, 2023.

  1. Krooq

    Krooq

    Joined:
    Jan 30, 2013
    Posts:
    196
    Unity Transport 1.3.4 depends on Collections 1.2.4 which is quite old, the newest Collections in LTS is 2.1.4
    This causes an issue because 2.1.4 contains breaking changes that need aligning in Transport.

    Can we get an update to the newer Collections package please?
     
  2. JohannRw

    JohannRw

    Unity Technologies

    Joined:
    Jan 26, 2022
    Posts:
    21
    Hi,
    Unity Transport 1.X won't be compatible with collections 2.X. This is due to breaking changes introduced with collection 2.X that led us to bump the transport version to 2.X.
    In other words, if you need to use the new collections package, you will need to install Unity Transport 2.X.
    It is available starting Unity editor 2022.2+
    - You can find the docs here : https://docs-multiplayer.unity3d.com/transport/current/about/index.html
    - And specifically the migration path from 1.X : https://docs-multiplayer.unity3d.com/transport/current/migration/
     
  3. simon-lemay-unity

    simon-lemay-unity

    Unity Technologies

    Joined:
    Jul 19, 2021
    Posts:
    441
    Also, Unity Transport 2.X doesn't (yet!) appear in the package manager by default. So you'll need to install it manually either through the package manager by adding the package by name and specifying the version, or by modifying the package manifest directly. The latest version is 2.0.2.
     
  4. Krooq

    Krooq

    Joined:
    Jan 30, 2013
    Posts:
    196
    Ah this is was the missing piece of the puzzle, thanks!