Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Deleted default environments and can't get them back

Discussion in 'Unity Remote Config' started by plotlessplot, Mar 30, 2020.

  1. plotlessplot

    plotlessplot

    Joined:
    Sep 16, 2012
    Posts:
    29
    When setting up the initial configuration for Remote Config in my current project, I created two environments, release and development (both lower-case).

    After doing the first PUSH, I went to the dashboard and noticed that I now had two more environments, Release and Development (both with the first letter in upper-case).

    I deleted the "new" ones and kept the ones I created, but I soon noticed that the development environment was not working correctly. The issue is that now I don't have the Development environment anymore and if I try to create one it tells me the name is reserved, so I currently have no way to set up an environment for development builds.

    Is there anything I can do?
     
  2. vd_unity

    vd_unity

    Unity Technologies

    Joined:
    Sep 11, 2014
    Posts:
    43
    Hi @theplotlessplot,

    We are sorry that you are experiencing issues, it is probably due to a different behaviour for different package versions.
    Could it be that you are using version before 1.1.0?

    We introduced CRUD for Environments in package version 1.1.0
    Legacy packages prior to version 1.1.0 automatically create two environments upon every fetch.

    If you would like to manage environments yourself we urge you to upgrade Remote Config to latest package version `1.3.0-preview.1`
    If you don't want to upgrade, you will only be able to access any environments except for your default environment (which you can set in the dashboard) and the Development environment.

    Please let us know if this helps,
     
  3. plotlessplot

    plotlessplot

    Joined:
    Sep 16, 2012
    Posts:
    29
    Updated from 1.0.9 to 1.3.0-preview1 and the default environments showed up again!
    Thank you very much!
     
    vd_unity likes this.