Search Unity

Deferred Shading in Unity 5 Personal

Discussion in 'Editor & General Support' started by Textfield272, Mar 25, 2015.

  1. Textfield272


    Mar 25, 2015
    I'm a bit confused as to how to activate the deferred renderer in Unity 5. When I change the rendering paths between deferred and forward, I see no change in the graphics output, and even when the setting is on deferred, it behaves like a forward renderer (only 4 pixel lights will render at any given time). This applies for both the viewport and an app built on the device (iPhone 6).

    I'm also reading mixed things about the availability of the deferred renderer. The documentation for Unity 5 states that the deferred renderer is a Unity Pro feature only, but the marketing material boasts all engine features being available in Unity Personal. I would assume that if the deferred renderer were not available in Unity 5 personal, it would be greyed out at the very least in the editor.

    I realized I had OpenGL ES 2.0 Emulation enabled. After turning that off the deferred renderer works properly in the editor, but only when I set the camera's rendering path to deferred. If I set it to "Player Settings," it will still render as forwards in the viewport, even though that option in Player Settings is set to deferred. Even with my main camera explicitly set to the deferred pipeline in its settings, the forward rendering path is still used on my actual device. The current graphics API selected is Metal.

    I tried looking at the player settings for the other platforms. The rendering pipeline option is a "Shared Setting Between Platforms," so it should have been checked as deferred for all of the others. Instead, it was checked as forwards. I changed it to deferred on one of them and all cameras now render as deferred in the viewport by default (when set to use the player settings), and when I looked at the player settings, all other platforms had been automatically set to deferred as well.

    However, when building for iOS, I still end up with the forward engine running. I tried changing the rendering settings for PC to forwards, which properly changed the cameras in the viewport and all the pipeline settings for all the platforms except for iOS, which stayed stuck on Deferred.

    I conclude then that the pipeline selection option for the iOS player settings is bugged, making it impossible to actually select the deferred renderer. I'll be looking for a workaround, and will probably post a bug report if somebody hasn't already.
    Last edited: Mar 25, 2015
  2. XuTenTen


    Apr 30, 2015
    I met the same problem too. I've also tried the above method, but can't run deferred on IOS. My test device is iphone6 & phones