Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Bug Deferred Rendering shadow flickering (URP - Unity 2023.2.5f1)

Discussion in 'Universal Render Pipeline' started by StephenManaWorks, Mar 29, 2024.

  1. StephenManaWorks

    StephenManaWorks

    Joined:
    Jun 21, 2022
    Posts:
    2
    We've been experiencing a strange shadow flickering whenever we attempt to use deferred rendering. I thought it might have been an issue with our project somewhere but have been able to replicate the problem in a new project.

    Here's an example of what we're seeing:


    I've tried a few things, such as adjusting shadow cascade settings, however that seems to just move the problem around.

    Here's an example with different shadow cascade settings:


    The problem seems to at least be loosely associated with distance from origin (the further away you get, the more likely it is to occur), and it's very particular about the camera angle, but I've found it difficult to accurately pinpoint contributing factors. The box I have in the videos isn't necessary to cause the flicker, I just found it easier to use as a point of reference when trying to locate buggy camera angles.

    The flickering affects both the editor and in-game camera, Mac and Windows builds, and I've found it significantly easier to get this flickering to occur in our game than it is in a blank project.

    I've been considering making a bug report about this, but thought I'd try getting some feedback here before I do.

    Thanks!
     
  2. StephenManaWorks

    StephenManaWorks

    Joined:
    Jun 21, 2022
    Posts:
    2
  3. Gasimo

    Gasimo

    Joined:
    Mar 3, 2015
    Posts:
    80
    This has been a bug plaguing me for quite a while as well. Happening on both 1980x1200 and 1920x1080 resolutions. Possibly partially related to this? Either way I have the same issue as you have on the video and know of few others. I will share the bug report so we can bump this even higher!