Search Unity

  1. Unity 2019.4 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  3. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

Default HDRP preset template scene - exposure, sky and colours way off for real world exterior

Discussion in 'High Definition Render Pipeline' started by newguy123, Jul 1, 2020 at 7:20 AM.

  1. newguy123

    newguy123

    Joined:
    Aug 22, 2018
    Posts:
    319
    Hi Guys

    I'm trying out the HDRP template. When just starting a new project with HDRP preset template, all looks almost pretty and all is well. However, on closer investigation, the exposure is set to fixed at 8.5.

    1) If I adjust this to align better with what you'd expect in real world, like EV 14 for example, then everything is way too dark.

    2) OK fine, lets assume the default of 8.5 is "correct". If I then add my fbx that was saved from 3ds Max where I use a linear workflow, all my material sample balls come in looking fine in the material folder where I saved them, however in scene, they are way too bright, bringing me back to the fact that 8.5 is too bright for a typical exterior scene.

    3) Is HDRP not yet aligned to use physical sun, sky and camera values? If so, what would be the workflow then to get the expected results? I can't make all my materials darker as that would make no sense. Only other option is to make the sun (default directional light) brighter?
     
  2. newguy123

    newguy123

    Joined:
    Aug 22, 2018
    Posts:
    319
    For a typical day exterior EV of 14:
    Increasing the default intensity from the default directional light from 10 000, up to something like 300 000, doesnt really work either. The scene's exposure feels a little better, but the skybox doesnt seem to update and is very dark, almost black
     
  3. newguy123

    newguy123

    Joined:
    Aug 22, 2018
    Posts:
    319
    Ah, I had to go back and adjust the "Sky and Fog Volume"'s HDRI Sky exposure independantly from the camera's exposure.

    Sort of ok, but now everything in shadow is pitch black as if no indirect environment light is getting it.....
     
  4. pierred_unity

    pierred_unity

    Unity Technologies

    Joined:
    May 25, 2018
    Posts:
    18
    Hello, the hdrp template level is not set up in a physically correct way. A new template will be coming eventually to fix this.


    For physical setup:

    The sun intensity should be at ~100 000 lux. Camera Exposure around 13 to 14 (depends on scene).

    If shadows are black, either rebake the scene (Lighting Settings window), or/and set the Visual Environment ambient mode to "Dynamic" in your volume.

    The sky can either be set-up with lux value or exposure.
     
    newguy123 likes this.
  5. newguy123

    newguy123

    Joined:
    Aug 22, 2018
    Posts:
    319
    Thanks @pierred_unity that makes sense
    For a second there I thought I was going bonkers!

    I'll try out the values you mentioned.

    1) Do you have a rough ETA for the new template?

    2) I'm struggling to get good shadows on a larger scene. I'm using 4 cascades over a distance setting of 500 and getting some artefacts, mostly in the closer to the cam cascades. (This is actually visible also in the current HDRP template, when you look at the planks laying on the ground's shadow, and also the legs of the table)
     
  6. pierred_unity

    pierred_unity

    Unity Technologies

    Joined:
    May 25, 2018
    Posts:
    18
    No worries. I understand it is indeed confusing. This template is however very old, and it wasn't really designed with physical correctness in mind, hence the discrepancy.

    I do not know the exact date for the new template release, but it will arrive eventually in 2020.2 (HDRP v10).

    The shadowing issues you see at short range could be related to the contact shadows. In your volume, add a "Contact shadows" override, and tune them (or disable them), and see if it helps.
     
    newguy123 likes this.
  7. newguy123

    newguy123

    Joined:
    Aug 22, 2018
    Posts:
    319
    @pierred_unity I'm struggling with this. I can't seem to get good, sharp looking shadows across my entire scene. Here's my shadow settings:
    upload_2020-7-3_1-6-42.png


    I added the contact shadow override in my volume. With it enabled, the shadows look clearer, but very grainy and full of artefacts.
    upload_2020-7-3_1-7-17.png

    With contact shadows disabled, smaller thinner objects's shadows fade a little, while the small building in the centre still has the same grainy edge artefact in it's shadow
    upload_2020-7-3_1-7-46.png

    Here's the shadow settings for my sun (directional light):
    upload_2020-7-3_1-8-13.png
     
    Last edited: Jul 2, 2020 at 11:13 PM
  8. newguy123

    newguy123

    Joined:
    Aug 22, 2018
    Posts:
    319
    I have these settings in the pipeline asset:
    upload_2020-7-3_1-10-30.png

    As you can see in this shot, the shadows in the distance quickly lose quality and is not clear and not sharp, and that is at a very short distance, maybe 50 or 100 meter. I need it to be sharp over 500 meter:
    upload_2020-7-3_1-12-27.png
     
unityunity