Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Daydream IAP bug causing Google Play rejection: "The app does not suppress system bars"

Discussion in '5.6 Beta' started by kexar66, Mar 21, 2017.

  1. kexar66

    kexar66

    Joined:
    Feb 27, 2013
    Posts:
    38
    When trying to buy a product via Unity In-App Purchasing service in Daydream app, there is system bar visible for a second. This is causing Google Play rejection. This is happening in Unity 5.6.0f1 and all earlier versions.
     
  2. nicholasr

    nicholasr

    Unity Technologies

    Joined:
    Aug 15, 2015
    Posts:
    129
    Hi @kexar66 - I'm sorry to learn Unity IAP with Daydream support caused a rejection.

    I've prepared a test build of Unity IAP, based upon 1.10.1, which has an untested fix. I'm planning on testing it later tonight.

    If you can reproduce what GooglePlay saw with a purchase on the Google Sandbox Store, and if you have time / wish to run another build, please would you let me know if this version of Unity IAP impacts the bad title-bar behavior?

    https://oc.unity3d.com/index.php/s/zEFpGi0L4DnvaCT
    "UnityEngine.Cloud.Purchasing-1.10.2-a1-daydreamvr-fixactivitydecoration.unitypackage (568 kB)"

    ## [??.??.??] - 2017-03-21
    ### Fixed
    - GooglePlay Daydream VR - Uses decoration-free Activity for purchasing

    (I normally dwell on the Unity IAP forums: https://forum.unity3d.com/forums/unity-iap.112/. Heads up @APalomo)
    (Thanks @joejo for calling attention here!)
     
    Arkade likes this.
  3. nicholasr

    nicholasr

    Unity Technologies

    Joined:
    Aug 15, 2015
    Posts:
    129
    Hi @kexar66 - From my testing this build of Unity IAP fixes that issue: the Unity game screen fades out, and fades into the Google Play VR purchasing screen, and does the same thing when the purchase is complete.

    I expect this will land in the release of Unity IAP after 1.10.1 which could be 1.10.2 or 1.11.0. So if you'd like to make this feature work for you now, please use this build of Unity IAP in place of your current.

    Best, Nick
     
    Arkade likes this.
unityunity