Search Unity

  1. Unity wants to learn about your experiences working on a Unity project today. We'd like to hear from you via this survey.
    Dismiss Notice
  2. Get the latest news, tutorials and offers directly to your inbox with our newsletters. Sign up now.
    Dismiss Notice
  3. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Bug Dark scenes created ghosted shadows

Discussion in 'VR' started by AcuityCraig, Apr 15, 2021.

  1. AcuityCraig

    AcuityCraig

    Joined:
    Jun 24, 2019
    Posts:
    44
    2019.4.22f1.
    URP (tried 7.3.1 and 7.5.3)
    VRTK (v3.3) with only Oculus integration and Oculus Android installed.
    Test on Quest and Quest 2

    I have recreated this issue in a blank scene in a brand new project with URP template. Add a plane for the "ground" and add a few scaled cubes set to static to make some shadows. A single baked directional light with an intensity of 0.1 or less. Bake the scene and then jump in VR via a quest headset with a link cable or do a build and test in the headset. All the shadows "ghost" as you move your head. Its more apparent when its a really dark shadow and you move your head toward something brighter. The faster you move your head the longer they go. Also this only shows in the headset so hard to get a screenshot of it.

    I've tried every setting in the renderer asset settings, single and multipass rendering, lighting bake settings, etc.

    The only shaders in the scene are URP/lit and URP/SimpleLit. Tried with and without post processing. I've been googling all day and not found anyone else reporting this issue but its easily recreated so maybe its a URP bug?

    Has anyone else seen this issue? Any ideas or settings anyone can think of I can try to troubleshoot this further?

    Thanks,
    Craig
     
unityunity