Search Unity

  1. Check out our Unite Austin 2017 YouTube playlist to catch up on what you missed. More videos coming soon.
    Dismiss Notice
  2. Unity 2017.2 is now released.
    Dismiss Notice
  3. The Unity Gear Store is here to help you look great at your next meetup, user group or conference. With all new Unity apparel, stickers and more!
    Dismiss Notice
  4. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  6. Unity 2017.3 beta is now available for download.
    Dismiss Notice

Dark Grey screen **FIX**

Discussion in 'Linux Editor' started by LevonRavel, Jan 2, 2017.

?

Did this solution help you

  1. Yes

    97.0%
  2. No

    3.0%
  1. LevonRavel

    LevonRavel

    Joined:
    Feb 26, 2014
    Posts:
    108
    *********** To the admins and or developers of unity ************
    could you please pass on a small message, It seems as though this solution is working for a few
    people. If your team was to automate this solution through the self deployment I am more then sure this issue would disappear. Some times the npm registry could be down or machines might muck something up but if its done locally its one less thing to worry about.
    *************************************************************************
    *** Thank you to malyzeli as he had the one liner idea ***

    [​IMG]
    For anyone getting the grey screen after install I have figured out how to fix it. (This is with Ubuntu other distros may vary slightly.)

    Method A.) Visual one liner (myself: visuals / wildcard and malyzeli original one liner)

    Method A:
    1.)
    Create a folder called unityfix in /Home/Downloads
    2.) Place the unity(someversion).deb file into unityfix folder
    3.) Open terminal copy paste the below

    cd ~/Downloads/unityfix && unityfile=$(stat -t *.deb --format=%n) && echo "please be patient extracting .deb file" && ar x $unityfile && echo "extracting data from tarballs" && tar -zxvf data.tar.gz -C ~/.local/share/unity3d/ --strip-components=6 ./opt/Unity/Editor/Data/Resources/Packages && cd ~/.local/share/unity3d/Packages && ls | grep tgz | xargs npm i --verbose && echo "Complete"

    once its finished it will say Complete you can now run unity..

    Explanation for people who are scared to enter strange code into terminal (you should be!):
    • unarchive (ar x) unity-editor.deb into actual directory (retrieving data.tar.gz and other stuff)
    • use tar to unzip (-z) and extract (-x) Packages from data.tar.gz (-f) into ~/.local/share/unity3d/ (-C), -v stands for verbose (you see what's going on in console) and --strip-components is there to get rid of full path in archive
    • change directory (cd) to ~/.local/share/unity3d/
    • list (ls) all files in directory and filter (grep) only tgz ones
    • pipe those files into xargs to call npm install on each of them
    • echo just prints the "text in quotes to the screen"
    • unityfile=$(stat -t *.deb --format=%n) its a wildcard so you dont have to know the filename $unityfile is the name that was found from the stat.


    Happy Coding
     
    Last edited: Jan 13, 2017
    SiloZero, Gurg, GraxRabble and 3 others like this.
  2. technotherion

    technotherion

    Joined:
    Jan 2, 2017
    Posts:
    1
    I had no idea that this would work. Honestly, I tried this as a last resort, because it seemed so ridiculous. I have no idea why I would have to run npm on those files manually... but hey, it worked!

    Thank you very much, man.

    Unity 5.6, Linux Mint (Ubuntu)
     
    LevonRavel likes this.
  3. jovaran1982

    jovaran1982

    Joined:
    Feb 27, 2016
    Posts:
    1
    Thanks alot, worked for me in openSUSE Leap 42.2. I follow your instructions step by step and run smoothly. :)
     
    LevonRavel likes this.
  4. bgrah

    bgrah

    Joined:
    Jan 4, 2017
    Posts:
    1
    Thanks for this. Saved me after 3h of frustrations. Ubuntu 16.10
     
    LevonRavel likes this.
  5. tomverwirrt

    tomverwirrt

    Joined:
    Jan 4, 2017
    Posts:
    1
    Thanks! This worked for me on both on Linux Mint 17.3 and Linux Mint 18.1.
     
    LevonRavel likes this.
  6. malyzeli

    malyzeli

    Joined:
    May 1, 2014
    Posts:
    5
    @LevonRavel First of all thanks a lot for your solution!

    Now let's improve it a bit, since I was personally quite annoyed by having to open three different pictures, examine them, read and write and click a lot of things.. :-D

    So my step-by-step automated solution is this:
    1. get the Unity installer .deb and note the filename, you'll need it in next step (lets say I saved it as unity-editor.deb)
    2. open terminal in directory where that file is and enter this one-liner do it for you (replace unity-editor.deb by the corresponding filename)
    Code (csharp):
    1. ar x unity-editor.deb && tar -zxvf data.tar.gz -C ~/.local/share/unity3d/ --strip-components=6 ./opt/Unity/Editor/Data/Resources/Packages && cd ~/.local/share/unity3d/Packages && ls | grep tgz | xargs npm install
    Wait for a while, since opening >2GB archive can take couple of minutes on slower machines.

    When terminal returns to command prompt, you are ready to launch Unity!

    Now you can also safely remove files unarchived from deb (data.tar.gz, control.tar.gz and debian-binary).

    Explanation for people who are scared to enter strange code into terminal (you should be!):
    • unarchive (ar x) unity-editor.deb into actual directory (retrieving data.tar.gz and other stuff)
    • use tar to unzip (-z) and extract (-x) Packages from data.tar.gz (-f) into ~/.local/share/unity3d/ (-C), -v stands for verbose (you see what's going on in console) and --strip-components is there to get rid of full path in archive
    • change directory (cd) to ~/.local/share/unity3d/
    • list (ls) all files in directory and filter (grep) only tgz ones
    • pipe those files into xargs to call npm install on each of them
     
    LevonRavel likes this.
  7. LevonRavel

    LevonRavel

    Joined:
    Feb 26, 2014
    Posts:
    108
    Thats totally awesome I just made another contribution.
     
    Last edited: Jan 5, 2017
    malyzeli likes this.
  8. rcano

    rcano

    Joined:
    Dec 28, 2016
    Posts:
    1
    Worked here as well! Ubuntu 16.04. Thanks for the fix!
     
    LevonRavel likes this.
  9. Vaile

    Vaile

    Joined:
    Oct 26, 2012
    Posts:
    1
    Worked great on Ubuntu 16.10. Thanks!
     
    LevonRavel likes this.
  10. tommel1234

    tommel1234

    Joined:
    Jan 5, 2017
    Posts:
    8
    Awesome guys !
     
    LevonRavel likes this.
  11. grash54

    grash54

    Joined:
    Jan 9, 2017
    Posts:
    1
    Fantastic! The one-liner work great!!! Fine Job! Thank-you! (Works on both Ubuntu 16.10 and Debian Sid)
     
    LevonRavel likes this.
  12. Adam2Marsh

    Adam2Marsh

    Joined:
    Mar 2, 2014
    Posts:
    4
    Worked for me aswel! Thanks.
     
    LevonRavel likes this.
  13. Nathan1_

    Nathan1_

    Joined:
    Oct 23, 2015
    Posts:
    16
    Thanks guys! I have unity working in linux.

    I tried all the solutions from other threads this is the only one that worked. To be specific I used @malyzeli's solution. Thanks!
     
    LevonRavel likes this.
  14. carlosbr

    carlosbr

    Joined:
    Mar 28, 2016
    Posts:
    3
    Thanks!! Working on Ubuntu 16.10
     
  15. cianmk

    cianmk

    Joined:
    Dec 20, 2016
    Posts:
    1
    Method B, it looks like the package's download page is bringing a 404 not found error. Here's npm's output.


    Code (Bash):
    1.  
    2. npm info trying registry request attempt 1 at 00:02:11
    3. npm http GET https://registry.npmjs.org/unityeditor-cloud-hub
    4. npm http 404 https://registry.npmjs.org/unityeditor-collab-history
    5. npm http 404 https://registry.npmjs.org/unity-editor-home
    6. npm ERR! 404 Not Found
    7. npm ERR! 404
    8. npm ERR! 404 'unityeditor-collab-history' is not in the npm registry.
    9. npm ERR! 404 You should bug the author to publish it
    10. npm ERR! 404 It was specified as a dependency of 'unity-editor'
    11. npm ERR! 404
    12. npm ERR! 404 Note that you can also install from a
    13. npm ERR! 404 tarball, folder, or http url, or git url.
    14.  
    15. npm ERR! System Linux 3.16.0-4-amd64
    16. npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "i" "--verbose"
    17. npm ERR! cwd /opt/Unity/Editor/Data/Resources/Packages
    18. npm ERR! node -v v0.10.29
    19. npm ERR! npm -v 1.4.21
    20. npm ERR! code E404
    21. npm verb exit [ 1, true ]
    22. npm http 404 https://registry.npmjs.org/unityeditor-collab-toolbar
    23. npm http 404 https://registry.npmjs.org/unityeditor-cloud-hub
    24. npm ERR!
    25. npm ERR! Additional logging details can be found in:
    26. npm ERR!     /opt/Unity/Editor/Data/Resources/Packages/npm-debug.log
    27. npm ERR! not ok code 0
    28.  
     
    LevonRavel likes this.
  16. LevonRavel

    LevonRavel

    Joined:
    Feb 26, 2014
    Posts:
    108
    thank you I removed that method please use method A as its worked 13x so far
     
  17. Nathan1_

    Nathan1_

    Joined:
    Oct 23, 2015
    Posts:
    16
    I just wanted to say... When I posted that I was getting it to run in ubuntu, and now I used the same fix to get Unity3D running on mint as well. Thank you!
     
    LevonRavel likes this.
  18. Flatlandish

    Flatlandish

    Joined:
    Jan 15, 2017
    Posts:
    1
    The above one-liner worked for me in Mint 17.3 to solve the 'grey screen' bug.

    To launch monodevelop, I had to install the following extra packages beyond what was pulled in by the .deb installer:

    realpath mono-complete gtk-sharp3 gnome-sharp2

    Everything seems to be working now.
     
    malyzeli likes this.
  19. Shuttle099

    Shuttle099

    Joined:
    Mar 19, 2013
    Posts:
    15
    Is it possible to use this for the .sh file on Arch?
     
    MathewAlden likes this.
  20. GraxRabble

    GraxRabble

    Joined:
    Jan 17, 2017
    Posts:
    3
    Solves my blank screen problem. I'm using Debian 8 "Jessie", amd64. Version Unity 5.6.0xb3

    Both the script and deb file extract the files within Editor/Data/Resources/Packages. The last step needed is installing them.

    @Shuttle099 Yes, it works for the .sh file. They forgot to run a script to install the nodejs packages. You should run Method A after installation with .deb or extraction with the .sh files.


    I'm looking into a way to modify the script to make it work. Open the .sh installation script with vim. It's a file with a script at the top and an archive file appended at the bottom. It appears you can add Method A to the script. Bold lines indicates where to add new code. It's around line 61. DO NOT USE, BUGGY. The problem is that when the installation script is executed as root, it will copy the files into the root's home directory instead of the user's home directory. I'll come back to see what I can do to fix the installation script.

    Code (Boo):
    1. ARCHIVE=`awk '/^__ARCHIVE_BEGINS_HERE__/ {print NR + 1; exit 0; }' $0`
    2.  
    3. # Actual extraction
    4. echo "Unpacking Unity 5.6.0xb3Linux ..."
    5. mkdir -p "${EXTRACT_DIRECTORY}"
    6. tail -n+${ARCHIVE} $0 | tar xj -C "${EXTRACT_DIRECTORY}"
    7.  
    8. # chrome-sandbox requires this: https://code.google.com/p/chromium/wiki/LinuxSUIDSandbox
    9. chown root "${EXTRACT_SUBDIR}/Editor/chrome-sandbox"
    10. chmod 4755 "${EXTRACT_SUBDIR}/Editor/chrome-sandbox"
    11.  
    12. echo "METHOD A GOES HERE"
    13. cp "${EXTRACT_SUBDIR}/Editor/Data/Resources/Packages/*" ~/.local/share/unity3d/Packages
    14. ls ~/.local/share/unity3d/Packages | grep tgz | xargs npm i
    15.  
    16. echo "Extraction complete. Run ${EXTRACT_SUBDIR}/Editor/Unity to begin"
    17.  
    18. exit
    19. __ARCHIVE_BEGINS_HERE__

    For the Deb File, you can add the following into the postinst file. I haven't tested it yet.

    Code (Boo):
    1. echo "METHOD A GOES HERE"
    2. cp opt/Unity/Editor/Data/Resources/Packages/* ~/.local/share/unity3d/Packages
    3. ls ~/.local/share/unity3d/Packages | grep tgz | xargs npm i
     
    Last edited: Jan 17, 2017
  21. LevonRavel

    LevonRavel

    Joined:
    Feb 26, 2014
    Posts:
    108
    thank you sooo freaking much man I have been using rider with unity on linux but i dont like it as much as monodevelop seems as though rider taps into monos debugger anyhow.. In any case thank you for helping with monodevelop such a freaking blessing..
     
  22. hashashin

    hashashin

    Joined:
    Mar 31, 2014
    Posts:
    20
    Great. Worked like a charm. Someday Unity needs to include that into the .deb triggers.
     
  23. SiloZero

    SiloZero

    Joined:
    Jan 26, 2017
    Posts:
    3
    This worked for me.
     
  24. GeeksEmpire

    GeeksEmpire

    Joined:
    Jan 14, 2017
    Posts:
    1
    solved issue on ubuntu 16.10
    thanks
     
  25. asaleh91

    asaleh91

    Joined:
    Jan 16, 2017
    Posts:
    1
    Thanks man Worked just fine
    Ubuntu 14.04 LS
     
  26. The-Britain

    The-Britain

    Joined:
    Mar 31, 2015
    Posts:
    529
    It almost makes me angry that this works. Thanks for the fix.
     
  27. Jesse_DuBord

    Jesse_DuBord

    Joined:
    Jan 15, 2017
    Posts:
    57
    I'm getting an error from the terminal when I run it in Linux Mint 18.1 64-bit. It says:

    jesse@Primus ~ $ cd ~/Downloads/Unity-Linux-5.6.0b3/unityfix/ && unityfile=$(stat -t *.deb --format=%n) && echo "please be patient extracting .deb file" && ar x $unityfile && echo "extracting data from tarballs" && tar -zxvf data.tar.gz -C ~/.local/share/unity3d/ --strip-components=6 ./opt/Unity/Editor/Data/Resources/Packages && cd ~/.local/share/unity3d/Packages && ls | grep tgz | xargs npm i --verbose && echo "Complete"
    please be patient extracting .deb file
    extracting data from tarballs
    tar: /home/jesse/.local/share/unity3d: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now

    Is there a fix or work-around for this?

    EDIT: I had to make the unity3d directory manually using the command "mkdir ~/.local/share/unity3d", then running the command above didn't show those two tar errors, anymore. However, the package "npm" isn't installed by default on a fresh install of Mint 18.1. I had to install the npm package from the software manager, then the process seemed to complete without issue.
     
    Last edited: Feb 2, 2017
  28. The-Britain

    The-Britain

    Joined:
    Mar 31, 2015
    Posts:
    529
    Yeah, npm is required for this to work.
     
  29. FuzzyLuke

    FuzzyLuke

    Joined:
    Dec 6, 2012
    Posts:
    39
    Hello

    I don't exactly have any grey windows popping up but I've been yet unable to start Unity at all on Ubuntu 16.04.

    I ran the commands as suggested by malyzeli, the output was:

    ./opt/Unity/Editor/Data/Resources/Packages/
    ./opt/Unity/Editor/Data/Resources/Packages/unityeditor-collab-history.0.6.6.tgz
    ./opt/Unity/Editor/Data/Resources/Packages/unityeditor-collab-toolbar.0.6.9.tgz
    ./opt/Unity/Editor/Data/Resources/Packages/package.json
    ./opt/Unity/Editor/Data/Resources/Packages/unity-editor-home.0.6.8.tgz
    ./opt/Unity/Editor/Data/Resources/Packages/unityeditor-cloud-hub-0.0.15.tgz
    ./opt/Unity/Editor/Data/Resources/Packages/unityeditor-collab-toolbar.0.6.6.tgz
    unity-editor@5.6.0 /home/lucas/.local/share/unity3d/Packages
    ├── unity-editor-home@0.6.8
    ├── unityeditor-cloud-hub@0.0.15
    ├── unityeditor-collab-history@0.6.6
    └── unityeditor-collab-toolbar@0.6.9

    npm WARN unity-editor@5.6.0 No repository field.
    npm WARN unity-editor@5.6.0 No license field.


    I still can't run Unity at all, when i try to launch it absolutely nothing happens. Any help would be appreciated...
     
  30. LevonRavel

    LevonRavel

    Joined:
    Feb 26, 2014
    Posts:
    108
    okay
    What I would do is remove unity all together
    sudo apt-get remove unity-editor -y

    Then download the Unity package again, once you get the package open up the terminal and type sudo apt-get install update.

    From here locate the unity package and cd to the directory
    do a sudo dpkg -i your unitypackage name

    Then sudo apt-get install -f to fix broken packages if that all goes well then do the one liner above and your finished.
     
  31. fitphilia

    fitphilia

    Joined:
    Apr 9, 2017
    Posts:
    1
    you, sir, are a life saver! Thank you so much for this.
     
  32. LevonRavel

    LevonRavel

    Joined:
    Feb 26, 2014
    Posts:
    108
    No Worries
     
  33. jasjuang

    jasjuang

    Joined:
    Jul 18, 2016
    Posts:
    1
    I ran the exact same command `cd ~/Downloads/unityfix && unityfile=$(stat -t *.deb --format=%n) && echo "please be patient extracting .deb file" && ar x $unityfile && echo "extracting data from tarballs" && tar -zxvf data.tar.gz -C ~/.local/share/unity3d/ --strip-components=6 ./opt/Unity/Editor/Data/Resources/Packages && cd ~/.local/share/unity3d/Packages && ls | grep tgz | xargs npm i --verbose && echo "Complete"` and it succeeds, I am able to see the output

    please be patient extracting .deb file
    extracting data from tarballs
    ./opt/Unity/Editor/Data/Resources/Packages/
    ./opt/Unity/Editor/Data/Resources/Packages/unityeditor-collab-history.0.6.10.tgz
    ./opt/Unity/Editor/Data/Resources/Packages/unity-editor-home.0.6.17.tgz
    ./opt/Unity/Editor/Data/Resources/Packages/package.json
    ./opt/Unity/Editor/Data/Resources/Packages/unityeditor-collab-toolbar.0.6.17.tgz
    ./opt/Unity/Editor/Data/Resources/Packages/unityeditor-cloud-hub-0.0.15.tgz
    npm info it worked if it ends with ok
    npm verb cli [ '/usr/bin/nodejs',
    npm verb cli '/usr/bin/npm',
    npm verb cli 'i',
    npm verb cli '--verbose',
    npm verb cli 'unityeditor-cloud-hub-0.0.15.tgz',
    npm verb cli 'unityeditor-collab-history.0.6.10.tgz',
    npm verb cli 'unityeditor-collab-toolbar.0.6.17.tgz',
    npm verb cli 'unity-editor-home.0.6.17.tgz' ]
    npm info using npm@2.15.11
    npm info using node@v4.8.3
    npm verb install initial load of /home/ubuntu/.local/share/unity3d/Packages/package.json
    npm WARN package.json unity-editor@5.6.0 No repository field.
    npm WARN package.json unity-editor@5.6.0 No README data
    npm WARN package.json unity-editor@5.6.0 No license field.
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/package.json
    npm verb cache add spec unityeditor-cloud-hub-0.0.15.tgz
    npm verb cache add spec unityeditor-collab-history.0.6.10.tgz
    npm verb cache add spec unityeditor-collab-toolbar.0.6.17.tgz
    npm verb cache add spec unity-editor-home.0.6.17.tgz
    npm verb addTmpTarball /home/ubuntu/.local/share/unity3d/Packages/unity-editor-home.0.6.17.tgz not in flight; adding
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb addTmpTarball validating metadata from /home/ubuntu/.local/share/unity3d/Packages/unity-editor-home.0.6.17.tgz
    npm verb tar unpack /home/ubuntu/.local/share/unity3d/Packages/unity-editor-home.0.6.17.tgz
    npm verb tar unpacking to /tmp/npm-25755-bbfa06bc/unpack-0516858d5993
    npm verb gentlyRm don't care about contents; nuking /tmp/npm-25755-bbfa06bc/unpack-0516858d5993
    npm verb addTmpTarball /home/ubuntu/.local/share/unity3d/Packages/unityeditor-cloud-hub-0.0.15.tgz not in flight; adding
    npm verb addTmpTarball /home/ubuntu/.local/share/unity3d/Packages/unityeditor-collab-history.0.6.10.tgz not in flight; adding
    npm verb addTmpTarball /home/ubuntu/.local/share/unity3d/Packages/unityeditor-collab-toolbar.0.6.17.tgz not in flight; adding
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb addTmpTarball validating metadata from /home/ubuntu/.local/share/unity3d/Packages/unityeditor-cloud-hub-0.0.15.tgz
    npm verb tar unpack /home/ubuntu/.local/share/unity3d/Packages/unityeditor-cloud-hub-0.0.15.tgz
    npm verb tar unpacking to /tmp/npm-25755-bbfa06bc/unpack-711d9f2ad2d4
    npm verb gentlyRm don't care about contents; nuking /tmp/npm-25755-bbfa06bc/unpack-711d9f2ad2d4
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb addTmpTarball validating metadata from /home/ubuntu/.local/share/unity3d/Packages/unityeditor-collab-history.0.6.10.tgz
    npm verb tar unpack /home/ubuntu/.local/share/unity3d/Packages/unityeditor-collab-history.0.6.10.tgz
    npm verb tar unpacking to /tmp/npm-25755-bbfa06bc/unpack-82be6a2ee231
    npm verb gentlyRm don't care about contents; nuking /tmp/npm-25755-bbfa06bc/unpack-82be6a2ee231
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb addTmpTarball validating metadata from /home/ubuntu/.local/share/unity3d/Packages/unityeditor-collab-toolbar.0.6.17.tgz
    npm verb tar unpack /home/ubuntu/.local/share/unity3d/Packages/unityeditor-collab-toolbar.0.6.17.tgz
    npm verb tar unpacking to /tmp/npm-25755-bbfa06bc/unpack-8e3f45b347a9
    npm verb gentlyRm don't care about contents; nuking /tmp/npm-25755-bbfa06bc/unpack-8e3f45b347a9
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb afterAdd /home/ubuntu/.npm/unity-editor-home/0.6.17/package/package.json not in flight; writing
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb afterAdd /home/ubuntu/.npm/unity-editor-home/0.6.17/package/package.json written
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb afterAdd /home/ubuntu/.npm/unityeditor-collab-toolbar/0.6.17/package/package.json not in flight; writing
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb afterAdd /home/ubuntu/.npm/unityeditor-collab-toolbar/0.6.17/package/package.json written
    npm verb afterAdd /home/ubuntu/.npm/unityeditor-cloud-hub/0.0.15/package/package.json not in flight; writing
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb afterAdd /home/ubuntu/.npm/unityeditor-cloud-hub/0.0.15/package/package.json written
    npm verb afterAdd /home/ubuntu/.npm/unityeditor-collab-history/0.6.10/package/package.json not in flight; writing
    npm verb correctMkdir /home/ubuntu/.npm correctMkdir not in flight; initializing
    npm verb afterAdd /home/ubuntu/.npm/unityeditor-collab-history/0.6.10/package/package.json written
    npm info install unity-editor-home@0.6.17 into /home/ubuntu/.local/share/unity3d/Packages
    npm info install unityeditor-collab-toolbar@0.6.17 into /home/ubuntu/.local/share/unity3d/Packages
    npm info install unityeditor-cloud-hub@0.0.15 into /home/ubuntu/.local/share/unity3d/Packages
    npm info install unityeditor-collab-history@0.6.10 into /home/ubuntu/.local/share/unity3d/Packages
    npm info installOne unity-editor-home@0.6.17
    npm verb installOne of unity-editor-home to /home/ubuntu/.local/share/unity3d/Packages not in flight; installing
    npm verb correctMkdir /home/ubuntu/.npm/_locks correctMkdir not in flight; initializing
    npm info installOne unityeditor-collab-toolbar@0.6.17
    npm verb installOne of unityeditor-collab-toolbar to /home/ubuntu/.local/share/unity3d/Packages not in flight; installing
    npm verb correctMkdir /home/ubuntu/.npm/_locks correctMkdir already in flight; waiting
    npm info installOne unityeditor-cloud-hub@0.0.15
    npm verb installOne of unityeditor-cloud-hub to /home/ubuntu/.local/share/unity3d/Packages not in flight; installing
    npm verb correctMkdir /home/ubuntu/.npm/_locks correctMkdir already in flight; waiting
    npm info installOne unityeditor-collab-history@0.6.10
    npm verb installOne of unityeditor-collab-history to /home/ubuntu/.local/share/unity3d/Packages not in flight; installing
    npm verb correctMkdir /home/ubuntu/.npm/_locks correctMkdir already in flight; waiting
    npm verb lock using /home/ubuntu/.npm/_locks/unity-editor-home-95008f5e28db0353.lock for /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home
    npm verb lock using /home/ubuntu/.npm/_locks/unityeditor-collab-toolb-4e08c27cce180c9d.lock for /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar
    npm verb lock using /home/ubuntu/.npm/_locks/unityeditor-cloud-hub-5f5d65a67dc328c6.lock for /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub
    npm verb lock using /home/ubuntu/.npm/_locks/unityeditor-collab-histo-a4ab31e0a9acd3fc.lock for /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history
    npm verb unbuild node_modules/unity-editor-home
    npm verb unbuild node_modules/unityeditor-collab-toolbar
    npm verb unbuild node_modules/unityeditor-collab-history
    npm verb unbuild node_modules/unityeditor-cloud-hub
    npm verb gentlyRm don't care about contents; nuking /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home
    npm verb gentlyRm don't care about contents; nuking /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar
    npm verb gentlyRm don't care about contents; nuking /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history
    npm verb gentlyRm don't care about contents; nuking /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub
    npm verb tar unpack /home/ubuntu/.npm/unity-editor-home/0.6.17/package.tgz
    npm verb tar unpacking to /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home
    npm verb gentlyRm don't care about contents; nuking /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home
    npm verb tar unpack /home/ubuntu/.npm/unityeditor-collab-toolbar/0.6.17/package.tgz
    npm verb tar unpacking to /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar
    npm verb gentlyRm don't care about contents; nuking /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar
    npm verb tar unpack /home/ubuntu/.npm/unityeditor-collab-history/0.6.10/package.tgz
    npm verb tar unpacking to /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history
    npm verb gentlyRm don't care about contents; nuking /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history
    npm verb tar unpack /home/ubuntu/.npm/unityeditor-cloud-hub/0.0.15/package.tgz
    npm verb tar unpacking to /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub
    npm verb gentlyRm don't care about contents; nuking /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub
    npm verb write writing to /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home/package.json
    npm info preinstall unity-editor-home@0.6.17
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home/package.json
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home/package.json
    npm verb about to build /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home
    npm info build /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home
    npm info linkStuff unity-editor-home@0.6.17
    npm verb linkBins unity-editor-home@0.6.17
    npm verb linkMans unity-editor-home@0.6.17
    npm verb rebuildBundles unity-editor-home@0.6.17
    npm info install unity-editor-home@0.6.17
    npm info postinstall unity-editor-home@0.6.17
    npm verb unlock done using /home/ubuntu/.npm/_locks/unity-editor-home-95008f5e28db0353.lock for /home/ubuntu/.local/share/unity3d/Packages/node_modules/unity-editor-home
    npm verb write writing to /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar/package.json
    npm info preinstall unityeditor-collab-toolbar@0.6.17
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar/package.json
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar/package.json
    npm verb write writing to /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub/package.json
    npm verb about to build /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar
    npm info build /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar
    npm info preinstall unityeditor-cloud-hub@0.0.15
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub/package.json
    npm info linkStuff unityeditor-collab-toolbar@0.6.17
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub/package.json
    npm verb linkBins unityeditor-collab-toolbar@0.6.17
    npm verb linkMans unityeditor-collab-toolbar@0.6.17
    npm verb rebuildBundles unityeditor-collab-toolbar@0.6.17
    npm info install unityeditor-collab-toolbar@0.6.17
    npm info postinstall unityeditor-collab-toolbar@0.6.17
    npm verb about to build /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub
    npm info build /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub
    npm verb write writing to /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history/package.json
    npm verb unlock done using /home/ubuntu/.npm/_locks/unityeditor-collab-toolb-4e08c27cce180c9d.lock for /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-toolbar
    npm info linkStuff unityeditor-cloud-hub@0.0.15
    npm info preinstall unityeditor-collab-history@0.6.10
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history/package.json
    npm verb linkBins unityeditor-cloud-hub@0.0.15
    npm verb linkMans unityeditor-cloud-hub@0.0.15
    npm verb rebuildBundles unityeditor-cloud-hub@0.0.15
    npm info install unityeditor-cloud-hub@0.0.15
    npm info postinstall unityeditor-cloud-hub@0.0.15
    npm verb readDependencies loading dependencies from /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history/package.json
    npm verb unlock done using /home/ubuntu/.npm/_locks/unityeditor-cloud-hub-5f5d65a67dc328c6.lock for /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-cloud-hub
    npm verb about to build /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history
    npm info build /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history
    npm info linkStuff unityeditor-collab-history@0.6.10
    npm verb linkBins unityeditor-collab-history@0.6.10
    npm verb linkMans unityeditor-collab-history@0.6.10
    npm verb rebuildBundles unityeditor-collab-history@0.6.10
    npm info install unityeditor-collab-history@0.6.10
    npm info postinstall unityeditor-collab-history@0.6.10
    npm verb unlock done using /home/ubuntu/.npm/_locks/unityeditor-collab-histo-a4ab31e0a9acd3fc.lock for /home/ubuntu/.local/share/unity3d/Packages/node_modules/unityeditor-collab-history
    npm verb validateInstall loading /home/ubuntu/.local/share/unity3d/Packages/package.json for validation
    unity-editor-home@0.6.17 node_modules/unity-editor-home
    unityeditor-collab-toolbar@0.6.17 node_modules/unityeditor-collab-toolbar
    unityeditor-cloud-hub@0.0.15 node_modules/unityeditor-cloud-hub
    unityeditor-collab-history@0.6.10 node_modules/unityeditor-collab-history
    npm verb exit [ 0, true ]
    npm info ok
    Complete​

    but I am unable to locate where to run Unity. Inside the `~/.local/share/unity3d` folder there is a `Unity` folder but there is nothing inside. I did a `locate Unity` and no executable shows up. Can you tell me what I am missing?