Search Unity

  1. Engage, network and learn at Unite Austin 2017, Oct 3 - 5. Get your ticket today!
    Dismiss Notice
  2. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  3. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice
  4. Unity 2017.1 is now released.
    Dismiss Notice
  5. Unity 2017.2 beta is now available for download.
    Dismiss Notice

D3D shader create error for shader [0x80070057] vs_5_0

Discussion in 'Editor & General Support' started by barjed, Sep 16, 2015.

  1. barjed

    barjed

    Joined:
    May 9, 2013
    Posts:
    68
    Hello everyone!

    We have recently noticed that our game build crashes on video cards not supporting DX11. We are using Unity 5.2. The error reported is this:

    So does this mean that our build somehow doesn't fall back to DX9 automatically when it fails to detect DX11 compatible card? I thought this is built-in in Unity. Is there something we should change in settings or perhaps in assets to prevent this from happening? When I enable Shader Model emulation in the Editor, everything works, so I think this means our game is compatible with the older SMs.

    I also tried running the game with the -dx9 parameter but it still crashes. We have googled extensively for this error and failed to find any solution.

    Please help.

    Thanks!
     
    AJEMadden likes this.
  2. fverhoef_rahalton

    fverhoef_rahalton

    Joined:
    Jul 31, 2014
    Posts:
    3
    I'm having the exact same issue - my game runs fine in the editor, both on DX9 and DX11 machines. But when building, the game crashes with the same error message as you're having when on a DX9 machine: D3D shader create error for shader [0x80070057] vs_5_0
     
  3. Sonoshee

    Sonoshee

    Joined:
    Jul 8, 2014
    Posts:
    77
    Same here! I was about to send a bug report when I realized my project is almost 2gb big.
    Should I send it guys?
     
  4. Sonoshee

    Sonoshee

    Joined:
    Jul 8, 2014
    Posts:
    77
    Just found a solution. not sure if it's the way to go but the build works just fine.

    Go to your project's Player Settings, then disable "Auto Graphics API for Windows" ( it should be enabled by default), then move Direct3D 9 up the list, and then hit Apply for the message that pops up. Build and see if that works for you, it did in my case.

    I'm not very informed about graphics cards compatibility, so I'd like from someone to confirm that the above solution is safe and doesn't risk breaking compatibility with other graphics cards.
     
  5. RomanBanana

    RomanBanana

    Unity Technologies

    Joined:
    Jun 23, 2015
    Posts:
    2
    Pushing Direct3D 9 up will cause it to be used instead of Direct3D 11
    We do not currently have a repro project for this bug. It would be great if you could submit a bug report even with a huge project and post the six digit case number here. Of course the smaller the project is the better :)
     
  6. Sonoshee

    Sonoshee

    Joined:
    Jul 8, 2014
    Posts:
    77
    Here is the bug report ID : 730265
    I didn't upload the project since I was able to reproduce it with a new empty project; for my case it was the Noise and Grain script from the Standard Assets that was causing this "incompatibility crash". I had to completely remove it, disabling it didn't work.
     
    Last edited: Sep 28, 2015
  7. pitchblackink

    pitchblackink

    Joined:
    Aug 28, 2013
    Posts:
    2
    Hi guys... same crash here. I've know what is causing the issue but I don't know how to fix it. The issue is with Noise and Grain image effect from Standard Assets package.

    Some days ago I started adding some post processing effects to my little game. That was my first clue because I had a previous build that doesn't crash.

    Today I took my time removing one by one of the image effects that I used and that was the problematic one. I check the options and the "use dx11" was unchecked. That was weird because the issue seems to be related to dx11. I'm not a shader dev (yet) so I don't know where the specific issue is. As a workaround I'm removing Noise and Grain image effect. Maybe you are using another conflictive image effect and you want to start checking.
     
  8. RomanBanana

    RomanBanana

    Unity Technologies

    Joined:
    Jun 23, 2015
    Posts:
    2
  9. GiTS_

    GiTS_

    Joined:
    Jan 30, 2015
    Posts:
    34
    Just had this issue today as well and thanks to pitchblackink found the cause, but mine wasn't from Noise and Grain but from the Depth of Field in the Standard Assets package, which I believe also has a DX11 option.
     
  10. pitchblackink

    pitchblackink

    Joined:
    Aug 28, 2013
    Posts:
    2
    Thanks RomanBanana and GiTS_, really appreciate.

    For those who really need a similar effect as Noise and Grain you can replace it by using Noise and Scratches that works well and can be tunned to produce a really-close or similar effect as Noise and Grain. I'm using it and I can't notice the difference hehe.
     
  11. EpicIndustries

    EpicIndustries

    Joined:
    Sep 28, 2014
    Posts:
    32
    Last edited: Oct 15, 2015
  12. EpicIndustries

    EpicIndustries

    Joined:
    Sep 28, 2014
    Posts:
    32
    Hey guys, just read on the ticket that this fix is coming in 5.3.2! I will update when it comes out and I can test it
     
  13. EpicIndustries

    EpicIndustries

    Joined:
    Sep 28, 2014
    Posts:
    32
    Apologies for the delay, buy FYI from what I can tell this has been fixed. Just wanted it on the record for anyone who stumbles across this in the future
     
  14. Sonoshee

    Sonoshee

    Joined:
    Jul 8, 2014
    Posts:
    77
    Thanks for letting us know!