Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on March 30, 2023, between 5 am & 1 pm EST, in the Performance Profiling Dev Blitz Day 2023 - Q&A forum and Discord where you can connect with our teams behind the Memory and CPU Profilers.
    Dismiss Notice

Cycle offset does not appear to work when using a blend tree (FIXED)

Discussion in 'Animation' started by Tyrathect, Jan 14, 2017.

  1. Tyrathect


    Jul 10, 2012
    I have two animations, a walk and a run, and I have a blend tree that blends from the walk to the run based on a float parameter.

    the walk starts on the left foot while the run starts on the right foot. I tried to fix this in unity by changing the cycle offset on the run so that the run loop starts on the left foot. I tried setting the cycle offset to 50 (for 50%) and also to 30 (the frame number).

    No value I put in cycle offset changes the result. The blend tree seems to ignore the offset.

    Am I missing something here?

    ANSWER: the value for cycle offset is in the range 0..1. So in my case, the correct value is 0.5. It would be nice if somewhere in the documentation it mentioned the range, or if unity gave you some indication that the value you entered isn't valid.
    MichaelJT likes this.
  2. MichaelJT


    Jan 28, 2015
    Having this exact problem.

    I thought the Cycle Offset was in frames too.