Search Unity

Customers having trouble with earlier version of unity

Discussion in 'Assets and Asset Store' started by igorlima97, May 25, 2017.

  1. igorlima97

    igorlima97

    Joined:
    Aug 1, 2015
    Posts:
    12
    I always try to upload my assets to the most recent version of unity8at this time) 5.6 , but lately my clients are having troubles while importing to version before 5.4x . That didn´t happen when I uploaded with 5.5x and before . It works with no troubles for some and with troubles for the rest... When Uploaded with 5.6 the same clients had problems with a package but bought another(uploaded also with 5.6 and didn´t have a single problem) . Anyone of the Dev team can answer to this , I have seen many publishers with the same problem sadly ;(
     
  2. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,146
    You should upload with the oldest possible version of Unity instead, not the latest. If you upload with 5.0, then anyone using Unity 5 can use it. If you upload with 5.6, then only people with 5.6 or later can use it.

    --Eric
     
    Kamil1064 likes this.
  3. Kamil1064

    Kamil1064

    Joined:
    Aug 14, 2014
    Posts:
    152
    Another tip: Especially with scripts you may set it to automaticly check unity version (it's commenting part of script like it's doing on currnet platform) so it will work on every version :) For example:
    #if UNITY_5_4_OR_NEWER
    myVariable = 10;
    #else
    myVariable = 8;
    #endif
    // and final code
    criticVariable = myVariable * Time.deltaTime;​
    That's just example, but I know calling "change scene" looks difference now then before :)