Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Let us know a bit about your interests, and if you'd like to become more directly involved. Take our survey!
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Ctrl +’ is not working, how to fix?

Discussion in 'Documentation' started by Eddiezouzou, Nov 29, 2016.

  1. Eddiezouzou

    Eddiezouzou

    Joined:
    Nov 29, 2016
    Posts:
    2
    I tried to search up at unity's scripting reference site by clicking Ctrl + '

    However, it does not work. How do I fix this problem?
     
  2. zombiegorilla

    zombiegorilla

    Moderator

    Joined:
    May 8, 2012
    Posts:
    7,278
    What are you expecting it to do?
     
  3. Kiwasi

    Kiwasi

    Joined:
    Dec 5, 2013
    Posts:
    15,648
    What code editor are you using? As far as I'm aware this only works with the version of MonoDevelop that comes with Unity. It's not a valid VisualStudio shortcut.

    I believe it's a shortcut to open the scripting reference to the highlighted key word. It's been a while since I've used it, I tend to already know where I want to go in the docs.
     
  4. Eddiezouzou

    Eddiezouzou

    Joined:
    Nov 29, 2016
    Posts:
    2
    After highlighting key word and pressing Ctrl + ', I am expecting it to jump into Scripting Reference.

    I am using Visual Studio.
     
  5. zombiegorilla

    zombiegorilla

    Moderator

    Joined:
    May 8, 2012
    Posts:
    7,278
    Huh.., that sounds useful.
     
  6. Shivarana

    Shivarana

    Joined:
    Oct 8, 2016
    Posts:
    5
    You're right, this function hasn't worked anymore since the website was last updated, ... a pity if you ask me.
    I suppose the shortcut website link coded in both Visual Studio and Monodevelop is no longer correct.

    Still you can do it manually. On the Website, choose Documentation then API Scripting and type in what you need info on...

    Sorry I coudn't be more helpfull but maybe moderators might relay the info higher 'cause this shortcut not working anymore really is a drawback for us all.
     
    Last edited: Dec 5, 2016
  7. Kiwasi

    Kiwasi

    Joined:
    Dec 5, 2013
    Posts:
    15,648
    We might be able to move this into the docs forum and tag one there. Unity staff do tend to be fairly responsive.
     
  8. Graham-Dunnett

    Graham-Dunnett

    Unity Technologies

    Joined:
    Jun 2, 2009
    Posts:
    4,288
    I've asked the doc team if anyone knows what's (not) happening. The docs are constantly being expanded and shipped in more modern and useful visual settings. My guess is that something simple hasn't been checked/tested.
     
    Kiwasi likes this.
  9. Baste

    Baste

    Joined:
    Jan 24, 2013
    Posts:
    3,346
    Is this still broken if you follow the instructions in the post that's stickied in this forum?
     
  10. Shivarana

    Shivarana

    Joined:
    Oct 8, 2016
    Posts:
    5
    Hi there Baste,

    as English isn't my mother tongue, could you explain what you mean by " stickied " ?

    Sorry to natives for this question ^^
     
  11. Baste

    Baste

    Joined:
    Jan 24, 2013
    Posts:
    3,346
  12. Shivarana

    Shivarana

    Joined:
    Oct 8, 2016
    Posts:
    5
    Thanks a lot for the link. I'm gonna give it a look and I'll let you know if it solved the problem.

    Have a nice weekend
     
  13. Shivarana

    Shivarana

    Joined:
    Oct 8, 2016
    Posts:
    5
    Hi again,

    Well it took me some time, as I'm using Monodevelop, to find the similar points mentioned in the link but all seems to be equivalent.

    As I mention before, it's not that the shortcut doesn't do anything, it opens the Unity website but tries to reach a page that no longer exists, probably due to the new website architecture.

    Here is the error message I get.

    Not Found / 404
    This page is no longer available. You might find what you are looking for by browsing through the links in our top menu.

    For example, using the shortcut on SetActive, my browser shows this path :
    https://unity3d.com/fr/support/documentation/ScriptReference/30_search.html?q=SetActive

    If I do it manually, the current path is :
    https://docs.unity3d.com/ScriptReference/30_search.html?q=SetActive

    And up to now, I haven't found a way, if it exists, to modify the path within Monodevelop to reach the correct page when using the shortcut.
     
  14. PaleDolphin

    PaleDolphin

    Joined:
    Dec 19, 2016
    Posts:
    2
    Checking in to say that Ctrl+' doesn't work for me as well. It shows the very same 404 page instead.

    It looks like links are broken. A fix for this would be greatly appreciated.
     
  15. PaleDolphin

    PaleDolphin

    Joined:
    Dec 19, 2016
    Posts:
    2
    Okay, so this might have to do something with Unity trying to translate things.

    Unity is adding the /ru/ part to my link (and it's adding /fr/ part to Shivarana's link, as you can see), and this causes the problem and the 404 page.

    Can we get a fix on this (no need to auto-redirect to other language, if we're using English)?
     
  16. DOUAUD

    DOUAUD

    Joined:
    Sep 30, 2016
    Posts:
    2
    same problem...
     
  17. Shivarana

    Shivarana

    Joined:
    Oct 8, 2016
    Posts:
    5
    Hi everybody.

    Me again.
    Any news about this??? It's been 2 months...

    zombiegorilla or Graham-Dunnett, have you heard anything new related to this very very very very very annoying thing?
    Thank you for letting us know.

    A great day to you all.
     
  18. COEzbay

    COEzbay

    Joined:
    Apr 5, 2016
    Posts:
    1
    Nope. Unfortunately this issue still does exist
     
  19. Denminion

    Denminion

    Joined:
    Sep 6, 2017
    Posts:
    1
    Hi guys & girls!

    Try to use Ctrl + Shift + ' instead.

    This works in MonoDevelop v5.9.6
     
    Last edited: Nov 9, 2017
  20. OttovanZanten

    OttovanZanten

    Joined:
    Dec 29, 2017
    Posts:
    2
    If the shortcut doesn't work you can just set it manually in the settins. Look for the Ctrl + ' binding, re-enter it and you'll see it change to ctrl + dead_acute, but that means it'll actually work with ctrl + '.

    If you're getting 404 messages I've heard changing the setting on the Unity website to English helps. It does seem to be a problem with translations.
     
  21. andrecmc

    andrecmc

    Joined:
    Feb 8, 2018
    Posts:
    1
    Solution that worked for me in Visual Studio:
    Highlight a word in the code editor and go to the following menu option: Help / Unity API Reference

    The default keyboard shortcut option for this menu option was not working for me so I needed to change it:
    You can take a look at the following link for the instructions on how to change a keyboard shortcut option: https://docs.microsoft.com/en-us/vi...stomizing-keyboard-shortcuts-in-visual-studio

    If you want to do it quickly:
    - Open menu Tools / Options
    - Select Keyboard
    - Type Help.Unity in the "Show commands containing" field
    - Highlight Help.UnityAPIReference
    - Select "Press shortcut keys" field
    - Type the keyboard shortcut you wand to use
    - Press the Assign Button
    - Press the Ok Button

    It should work now.
     
  22. Pippkorn

    Pippkorn

    Joined:
    Feb 16, 2018
    Posts:
    1
    Thank you so very much. I'm currently teaching myself some simple Unity and coding stuff in my free time, and tried following the built-in Unity tutorial and it required use of this command. It did not work for me so I of course tried to fix it by Googling for an answer. Finding this old thread (it's from 2016!) with other users having the same issue immediately had me lose my hope.

    But, at the very bottom, here you are, with the answer. +1
     
    unity_V-qb3f8Pta5MoQ likes this.
  23. wart101

    wart101

    Joined:
    Mar 8, 2015
    Posts:
    1
    Fantastic, thanks, can get by without it but it does make life easier.
     
  24. unity_V-qb3f8Pta5MoQ

    unity_V-qb3f8Pta5MoQ

    Joined:
    May 12, 2018
    Posts:
    1
    Thank you a lot.
    I'm try to learn Unity and this kind a stuff helps a lot.

    In Visual Studio 2017, the original hotkey is CTRL + H (on windows), but, CTRL + ' is simplier.
    -------------------------
    Edit:
    In the Visual Studio 2017, installed with the Unity 2018.1, I need to change one configuration, because they don't load the Api Documentation... The internal browser (the wonderful I.E.) can't process the html data.

    To solve this, I need to change on option in the unity "module" in the Visual Studio 2017, let's go:
    - Access "Tools" > "Options".
    - In the Options window, access "Tools for Unity" > "General"
    - Find there the option: "Use external browser" (subitem of "Documentation")
    - Change the value to "TRUE"

    The unity documentation use by default the Visual Studio internal Default Browser (IE/edge) and that "wonderful tool" doesn't work at all...
     
    Last edited: May 12, 2018