Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

CreateAssetMenu not appearing in Create-menu

Discussion in 'Scripting' started by Pixygon, Jan 13, 2018.

  1. Pixygon

    Pixygon

    Joined:
    May 9, 2013
    Posts:
    4
    I've made several ScriptableObjects, where instances can be created using the Create submenu in the project. This has worked fine the last three months, but now I don't get the menu option at all, for any of my scriptable objects. I've tried deleting and re-downloading the project, edit the scripts to see if it appears again, changing the name of the object in the create menu, but with no luck.
    Is there anyone that have an idea about what could have happened?
     
  2. ExplosiveBarrels

    ExplosiveBarrels

    Joined:
    Oct 18, 2016
    Posts:
    3
    This bug is happening to me now too.
    Did you ever find a solution?

    EDIT: Actually, nevermind, I solved my particular case. I had switched most of my ScriptableObjects to inherit from the same base class, but that base class was accidentally a MonoBehaviour instead of ScriptableObject, so one quick fix there re-enabled them all.
     
    Last edited: Aug 12, 2018