Search Unity

  1. Get all the Unite Berlin 2018 news on the blog.
    Dismiss Notice
  2. Unity 2018.2 has arrived! Read about it here.
    Dismiss Notice
  3. We're looking for your feedback on the platforms you use and how you use them. Let us know!
    Dismiss Notice
  4. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Learn more.
    Dismiss Notice
  6. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  7. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  8. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

CreateAssetMenu not appearing in Create-menu

Discussion in 'Scripting' started by Pixygon, Jan 13, 2018.

  1. Pixygon

    Pixygon

    Joined:
    May 9, 2013
    Posts:
    2
    I've made several ScriptableObjects, where instances can be created using the Create submenu in the project. This has worked fine the last three months, but now I don't get the menu option at all, for any of my scriptable objects. I've tried deleting and re-downloading the project, edit the scripts to see if it appears again, changing the name of the object in the create menu, but with no luck.
    Is there anyone that have an idea about what could have happened?
     
  2. ExplosiveBarrels

    ExplosiveBarrels

    Joined:
    Oct 18, 2016
    Posts:
    3
    This bug is happening to me now too.
    Did you ever find a solution?

    EDIT: Actually, nevermind, I solved my particular case. I had switched most of my ScriptableObjects to inherit from the same base class, but that base class was accidentally a MonoBehaviour instead of ScriptableObject, so one quick fix there re-enabled them all.
     
    Last edited: Aug 12, 2018 at 9:10 PM