Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Create a Space Shoot 'Em Up With Unity but...

Discussion in 'Editor & General Support' started by Brian-Washechek, Sep 28, 2019.

  1. Brian-Washechek

    Brian-Washechek

    Joined:
    Aug 5, 2015
    Posts:
    725
    Well I'm going to upload this I have no idea where my problem even is... The problem is when you fire a bullet. Take a look at it please.
     
  2. JasonBricco

    JasonBricco

    Joined:
    Jul 15, 2013
    Posts:
    936
    Can't you provide any more information? If you're going to ask people to help you should try to make their lives as easy as possible, rather than uploading an entire project and telling them to dig through it trying to find some arbitrary problem that you haven't explained.

    I don't know what's wrong when you fire a bullet. Possible options:

    1. "Fire1" isn't defined as a button.
    2. PlayerController isn't attached to a GameObject in the scene.
    3. 'shot' is null.
    4. 'shotPoint' is null.
    5. shotPoint is in the incorrect location or has the incorrect rotation.
    6. 'shot' doesn't have PlayerShot attached.
    7. Or, if it uses 'MovingObject', then maybe moveSpeed hasn't been set.
    8. Some collider is causing the bullet to be destroyed prematurely.

    Who even knows. Here are some useful things you could say:

    - "When I fire a bullet, Unity gives me <this> error.
    - "When I fire a bullet, the bullet acts in <this> way and I want it to act in <this> way.
    - "I press the button to fire a bullet and nothing happens."

    You get the idea. Telling how you've tried to fix it is helpful as well.
     
  3. Brian-Washechek

    Brian-Washechek

    Joined:
    Aug 5, 2015
    Posts:
    725
    Heh-heh. For some reason the problem solved itself! It happened out of nowhere. I do thank you greatly, but your assistance is no longer needed. Heh-heh... Yeah...
     
unityunity