Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

[CRASH] Unity with Windows 10 Fall Creators Update (1709) and Nvidia Issue

Discussion in 'Editor & General Support' started by rmgomez, Nov 22, 2017.

  1. rmgomez

    rmgomez

    Joined:
    Oct 2, 2014
    Posts:
    18
    Hello im having serious issues with unity after updating to FCU (1709) .

    Right after updating my S.0 i went on to Geforce Experience and updated my Nvidia driver to v388.31.
    I had no issues when gaming (Overwatch and Rocket League). Next day at work when i tried to use Unity 3D Engine v5.6.1 and 5.6.4 (wich uses the Nvidia GPU) i got multiples BSOD (7 times)

    The crash happens in the editor, not in Play mode. Right before a BSOD i get a full CPU/GPU use from Unity.

    The blue screen error is:

    The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

    Event-ID: 41 (Kernel-Power)
    Keyword: 0x8000400000000002

    System Info:
    - Using Default Settings (NO OVERCLOCK, FACTORY DEFAULT)
    - Laptop Asus Rog Strix GL553VE
    - Geforce GTX 1050 TI
    - Intel Core i7-7700HQ CPU 2.80 Ghz
    - 16GB RAM
    - Display 1920x1080, 60 Hz

    Things i tried without success (in order):
    - Reinstalling the 388.31 driver
    - Rolling back to Driver 387.92
    - Updating the Onboard Intel Driver (Recomended by Microsoft Forum)

    The only temporary solution i found is to force Unity to use the Onboard Intel Graphic card. Doing that the BSOD stopped but the performance was reduced significantly.

    I didnt have this issue before updating to Fall Creators Update and i cant roll back.

    Any ideas?
    Thanks
     
  2. Joe-Censored

    Joe-Censored

    Joined:
    Mar 26, 2013
    Posts:
    11,847
    This type of error is caused by hardware issues or drivers. Overheating issues, bad PSU, bad motherboard, needing a motherboard BIOS update, problems with software drivers, etc.
     
    bugfinders likes this.
  3. rmgomez

    rmgomez

    Joined:
    Oct 2, 2014
    Posts:
    18

    UPDATE: * HOW I SOLVED MY ISSUE*


    Well I contacted Nvidia Customer Support and they helped me fix the issue i had.
    I recomend you to do the same, the engineers are very easy to talk to and they respond quickly.
    Link to the Nvidia Support: http://www.nvidia.com/object/support.html (Open chat at the bottom of the page)

    Steps i had to do while folowing Nvidia Customer Support:

    > Clean install of the latest driver directly from the nvidia site *This didnt fix the issue.*
    http://www.nvidia.com/Download/index.aspx?lang=en-us (not from Geforce Experience)

    When Installing:
    *Check Al boxes
    *Check Clean Install

    > They asked to reinstall the app with the issue (Unity 3D) *This didnt fix the issue.*

    > The last thing was to go to:
    Nvidia Control Panel > Manage 3D Settings > Program Settings Tab > Choose the program to customize (or find the exe if not in the list)

    Set this options:
    * Ambient Occlussion - OFF
    * Power Management Mode - Prefer Maximum Performance
    * Threaded Optimization - ON
    * Triple Buffering - OFF
    * Vertical Sync - OFF

    Then hit apply. *This solved my issue*

    I dont know wich option solved the issue as i was having a BSOD and i didnt want to try one by one. But the Representative told me its usually the Power Management Mode - Prefer Maximum Performance)

    Hope this help somebody with a similar situation.
     
    MetalInvador likes this.
  4. valyard

    valyard

    Unity Technologies

    Joined:
    Jun 4, 2010
    Posts:
    291
    I recently had a similar issue but not ending with a BSOD.

    Unity was crashing sometimes on my Windows 10 machine either when baking lightmaps or during building or just when Unity is being built from source. This is what I was seeing in the logs with DX11 Debug Layer enabled:

    Code (CSharp):
    1. [00:21:55] Enlighten: Started  Light Transport job, hash: 0xbac705ca3d9ec64528f311724e464562
    2. D3D11: Removing Device.
    3. d3d11: failed to create buffer (target 0x1 mode 0 size 3072) [0x887A0005]
    4. D3D11 WARNING: ID3D11DeviceContext:DrawIndexed: An Index Buffer is expected, but none is bound. This is OK, as reading from a missing Index Buffer is defined to return 0.However the developer probably did not intend to make use of this behavior.  [ EXECUTION WARNING #357: DEVICE_DRAW_INDEX_BUFFER_NOT_SET]
    5. Assertion failed on expression: 'SUCCEEDED(hr)'
    6. (Filename: E:\Work\Unity\unity\Runtime/GfxDevice/d3d11/D3D11Window.cpp Line: 196)
    7. // HRESULT hr = m_SwapChain->Present(0, 0);
    In Windows Event Viewer at the same moment this warning appeared:
    Display driver nvlddmkm stopped responding and has successfully recovered.

    So, Unity crashes the driver and after that Unity is stuck in a broken state and continues spitting errors.

    The interesting thing is that only Unity does this. I play games on this machine and have never seen such behavior. From what I noticed, crashes are always close to GPU clock increase from idle. But even if I run a gpu test in parallel (maxing GPU clock), Unity still crashes the driver…

    I think I tried everything googleable, but I managed to stop this from happening by turning off TDR as described here https://docs.microsoft.com/en-us/windows-hardware/drivers/display/tdr-registry-keys

    Nothing else helped. It seems that Unity can block GPU with some work so that TDR thinks that GPU is frozen and kills the driver. This makes my machine vulnerable to GPU freezes (i.g. being in an infinite loop), but I can't get Unity working on this machine otherwise )8
     
  5. Brathnann

    Brathnann

    Joined:
    Aug 12, 2014
    Posts:
    7,195
    Your issue sounds similar to mine, so I was hopeful this would fix it, but no luck.

    I'm getting a BSOD on Unity only when I do a 3D project or if I make a 2D project and add a skybox material and then turn on Auto Generate. Unity starts to bake, then displays the error Ambient Probes job failed with error code: 2 ("Failed to bake the ambient probe"). Before crashing Windows.

    I don't get a BSOD on any games or if I run any stress test, they all pass. I'm really baffled by this.
     
  6. Ge-Xurong

    Ge-Xurong

    Joined:
    May 5, 2016
    Posts:
    1
    oh my God. Thanks to Asty. It seems like set Nvidia Control Panel option really help me solve this problem ! I am still tesing my scenes. And if my problem appears again I be will back here to tell you. I hope not. Thanks again.
     
  7. Brogan89

    Brogan89

    Joined:
    Jul 10, 2014
    Posts:
    244
    This fixed my issue too. Thank you so much @Asty . This was really starting to annoy me. I would either be getting BSOD or Unity's window would go blank and would give this error in the editor.log
    d3d11: failed to create buffer (target 0x1 mode 0 size 960) [0x887A0005]
    and I could only close unity by ending task in task manager.
     
  8. bostik007

    bostik007

    Joined:
    Feb 6, 2019
    Posts:
    1
    @Asty
    Thanks thanks thanks thanks!!
    You saved my project
     
  9. nypehb

    nypehb

    Joined:
    Aug 14, 2020
    Posts:
    8
    I had a similar problem. Unity was crashing and even reboot my computer sometimes. Without any reason. I tried many different things like: reinstalling Unity, updating drivers, changing NVidia settings, turning off Microsoft Defender, turning off TdrLevel, etc. All of it didn't help.

    What is interesting - crashes and sudden reboots occurred only when working with Unity. And then not immediately. Sometimes the crash happened after 5 minutes of work in play mode, and sometimes after an hour.

    But I managed to fix this problem by updating BIOS. It turned out that there were a lot of updates for the BIOS of the motherboard, and apparently, Unity somehow was activating those hardware functions that required updates at the BIOS level.

    In general, if you have a similar problem - try updating the BIOS.
     
    Last edited: Aug 13, 2023
  10. MetalInvador

    MetalInvador

    Joined:
    Oct 1, 2018
    Posts:
    8
    Just want to give the flowers for this answer. Yesterday I had to update my NVIDIA drivers and games & other software had no problem running except for Unity. I spent a whole day deleting libraries, re-installing drivers & projects, unity versions, etc. but finally stumbled upon this solution.

    I am not too fond on the technical side of things so I do not understand how nor why this solved the issue, but I can safely say that this fix is still relevant in 2024! Thank you :)