Search Unity

Crash: pthread_create throws 'std::runtime_error' on 'libmono.so'

Discussion in 'Linux Editor' started by blipi, Oct 21, 2015.

  1. blipi

    blipi

    Joined:
    Feb 12, 2013
    Posts:
    7
    OS: Ubuntu 12.04.5 amd64
    Running latest: 5.1.0f3+2015091501_amd64
    All dependencies met.

    Complete log on:
    https://travis-ci.org/gpascualg/BouncingBall/builds/86698344
     
  2. FuzzyQuills

    FuzzyQuills

    Joined:
    Jun 8, 2013
    Posts:
    2,869
    I would suggest updating your dependencies if possible, I don't see any other reason it would crash on pthread_create... :D Could also mean a unity bug wih the way they're handling parameters for the function call.
     
  3. blipi

    blipi

    Joined:
    Feb 12, 2013
    Posts:
    7
    Well, it's as updated as it can be on an Ubuntu 12.04. All dependencies for Unity are installed and I ensure both build-essential and pthread-stubs are up to date... Still not working :/
     
  4. FuzzyQuills

    FuzzyQuills

    Joined:
    Jun 8, 2013
    Posts:
    2,869
    Ok then... I may as well go and look this up to see if this is a common issue with certain libs (not necessarily unity's)

    edit: corrected a typo (me fingers a too fast!!!!)
     
  5. FuzzyQuills

    FuzzyQuills

    Joined:
    Jun 8, 2013
    Posts:
    2,869
    Ok, might as well wait for Unity to answer this, I looked it up and generally it's due to incorrect coding of exception handlers. (I can't see this being unity's issue however)

    Actually, and idea; is it Unity Editor stuffing up or is it a built game stuffing up? I presume it's the editor.

    EDIT: Wait a sec... I think I've got it; by looking at that, it appears it goes to start up an enlighten worker thread and fails with the runtime error. That definitely appears to be a bug or discrepancy in the editor/build. Anyone know a good UT member I can mention this to? :D
     
  6. blipi

    blipi

    Joined:
    Feb 12, 2013
    Posts:
    7
    The project builds fine in other OSes, such as Ubuntu 14.04, OSX and Windows 10. OSX and Windows are using Unity 5.2.x but Ubuntu 14.04 is using the same beta as that 12.04.

    So I guess it's not a project issue. Maybe 12.04 has some old libraries which Unity fails to correctly use... Just guessing.

    Thank you!
     
  7. FuzzyQuills

    FuzzyQuills

    Joined:
    Jun 8, 2013
    Posts:
    2,869
    You're welcome. :) So it's only version 12.04 that isn't working? I would suggest backing up stuff and putting the latest (or 14.04, whichever one you prefer. ;)) version of Ubuntu on then. :)
     
  8. blipi

    blipi

    Joined:
    Feb 12, 2013
    Posts:
    7
    I can't do that, it's an external server that is used for continuous integration (ie. automitic building + tests). It uses ubuntu 12.04 and there's nothing I can do about it.
     
  9. FuzzyQuills

    FuzzyQuills

    Joined:
    Jun 8, 2013
    Posts:
    2,869
    Ok, fair enough, I was simply making suggestions. :)
     
  10. blipi

    blipi

    Joined:
    Feb 12, 2013
    Posts:
    7
    Sure, I was just saying, no pun intented ;) You've been helpful so far and the only one to answer with possible solutions, so thank you again =)