Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug Continously Getting this issue: "Failed copying file unity/external to Assets/external" in Unity

Discussion in 'Editor & General Support' started by factober, Nov 11, 2023.

  1. factober

    factober

    Joined:
    Sep 15, 2023
    Posts:
    5
    Issues I am getting:

    1) On the first drag and drop it failed with this error message:
    "Failed copying file unity/external to Assets/external.
    UnityEngine.GUIUtility:processEvent (int,intptr,bool&)"

    2) On subsequent drag and drops it failed continuously with the same error message:
    "Assertion failed
    UnityEngine.GUIUtility:processEvent (int,intptr,bool&) (at /home/bokken/build/output/unity/unity/Modules/IMGUI/GUIUtility.cs:197)"

    Tried to find a solution all over the internet. I didn't find any solution to this issue.

    Tried in following versions which produced the same issue:
    Unity: 2022.3.12f1, 2022.3.13f1 and 2023.1.20f1.
    OS: Ubuntu 22.04
    Can't drag and drop in asset browser: .unitypackage, .fbx.

    Please refer attached error screenshots for more clarity.
     

    Attached Files:

  2. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    5,014
    Is that a path in your project? Or are you dragging a path into Unity?

    From where (path) to where (window or path in project hierarchy) do you drag the file (file name with extension)?
     
  3. factober

    factober

    Joined:
    Sep 15, 2023
    Posts:
    5
    No, it seems some logical description indicates copying failed from an outside file in Unity Asset Explorer.

    When I dragged fbx or unitypackage file from the Ubuntu filesystem to unity assets area, instead of showing an import popup it showed me that error.

    I can import files by right click menu. But, dragging and dropping is not working.