Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

Resolved Constant error with "UnityEditor.Experimental.AssetImporters.ScriptedImporter"

Discussion in '2021.2 Beta' started by sacb0y, Sep 7, 2021.

  1. sacb0y


    May 9, 2016
    I'm getting this error:

    Code (CSharp):
    1. TypeLoadException: Could not resolve type with token 01000051 from typeref (expected class 'UnityEditor.Experimental.AssetImporters.ScriptedImporter' in assembly 'UnityEditor, Version=, Culture=neutral, PublicKeyToken=null') assembly:UnityEditor, Version=, Culture=neutral, PublicKeyToken=null type:UnityEditor.Experimental.AssetImporters.ScriptedImporter member:(null)
    2. UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at <462b82a54ea94e5da1dfbbc027ef8bd0>:0)
    A million times and I don't know why, considering this seems to be out of experimental with unity 2021 I'm not sure this is supposed to exist in this form.

    The project is upgrading from unity 2019.4, and seems to also break the package manager.

    I've also tried removing all assets using "AssetImporter" but the error continues.

    It does not appear in safe mode, and does not trigger safe mode when loading unity.

    I've done a full reimport this does not fix it.

    I've tried "Reset Packages to Defaults" it does not fix it.

    This is in Unity 2021.2.0b10.3401

    Please help!
  2. sacb0y


    May 9, 2016
    turns out the issue was the older version of the substance source asset, updating finally fixed this.

    Issue was in a dll so i couldn't see where it was coming from
    LeonhardP likes this.