Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Question Compatible Unity versions for Unity Gaming Services Analytics

Discussion in 'Unity Analytics' started by JHSV, Nov 16, 2022.

  1. JHSV

    JHSV

    Joined:
    Jul 11, 2013
    Posts:
    27
    The FAQ says that version 2019.4 is the minimum for running Unity Game Services Analytics. However, on the documentation page for the new analytics package (com.unity.services.analytics, https://docs.unity3d.com/Manual/com.unity.services.analytics.html), the supported Unity versions section of the page excludes a few versions after 2019.4, including 2021.x.

    Does this mean that Unity 2021.x versions are actually incompatible with Unity Game Services Analytics? Can I use com.unity.services.analytics in 2021.x somehow? Or can I use the Unity Game Services Analytics with the older analytics library, com.unity.analytics in Unity 2021.x? Or is it necessary to upgrade Unity to one of the supported versions?
     

    Attached Files: