Search Unity

  1. Get all the Unite Berlin 2018 news on the blog.
    Dismiss Notice
  2. Unity 2018.2 has arrived! Read about it here.
    Dismiss Notice
  3. We're looking for your feedback on the platforms you use and how you use them. Let us know!
    Dismiss Notice
  4. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Learn more.
    Dismiss Notice
  6. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  7. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  8. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Collision detection during camera blending

Discussion in 'Cinemachine' started by cRUSh75, Mar 13, 2018.

  1. cRUSh75

    cRUSh75

    Joined:
    Jun 8, 2017
    Posts:
    18
    Hi,

    I love the way how camera blending is possible with cinemachine. Especially I like the ease in and out setting. So I made a terrain and some cams on different positions. Most of the time the camera just blends fine but it happens, that the camera flies through the terrain or through buildings, dependent on if there are some small hills between them or buildings. I was thinking that the cam collision setting would take care about the blending time as well.

    So are my settings wrong or is blending ignoring collisions?
     
  2. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,416
    Your settings are not wrong. Blending ignores collisions.
     
  3. cRUSh75

    cRUSh75

    Joined:
    Jun 8, 2017
    Posts:
    18
    Good to know, thank you very much for the information. I think I will find a way to work around this...