Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Collaborate headaches all day

Discussion in 'Unity Collaborate' started by milesmajefski, Aug 3, 2016.

  1. milesmajefski

    milesmajefski

    Joined:
    Sep 4, 2013
    Posts:
    9
    My friend added a large amount of assets to our project this morning. I tried to download the update, but every time it finishes the download it says there was an error: Operation timed out after 0 milliseconds with 0 out of 0 bytes received.

    I did find an error in the editor log. Here's an excerpt:
    [CEF] TypeError: undefined is not a function
    at file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:25:28514
    at file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:26:2895
    at i (file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:13:25720)
    at file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:13:25892
    at n.$eval (file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:14:1473)
    at n.$digest (file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:13:31927)
    at n.$apply (file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:14:1740)
    at file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:14:9025
    at e (file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:12:16700)
    at file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js:12:18123 in file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js at line 13
    [CEF] Error changing state, detail: event: in file:///C:/Users/miles/AppData/Roaming/Unity/Packages/node_modules/unityeditor-collab-history/dist/assets/unityeditor-collab-history.js at line 39


    Any ideas?
     
  2. bradunity

    bradunity

    Unity Technologies

    Joined:
    Nov 12, 2013
    Posts:
    195
    That sounds very strange. If you can repro the issue, we'd be able to understand more if you run the Editor with the command line option of -enableCollabEventLogs, repo the issue, send a bug report (Help and select Report a bug), and tell us what the bug ID is (either here or via collabsupport@unity3d.com). We can then review your logs and help determine what might be going on.
     
  3. milesmajefski

    milesmajefski

    Joined:
    Sep 4, 2013
    Posts:
    9
    I fixed it! I had previously installed version 5.4.0f2 then I installed f3 over it. So I uninstalled, then reinstalled f3 and re-downloaded the project and everything is fine, no errors. Yay!

    Some fixes I had tried before that:
    -reimport all assets
    -download the whole project to another folder
    -rename the node_modules folder
    -delete the 4 collaborate cache files indicated in this info:

    In your AppData folder, go to LocalLow->Unity->Browser->Cache->Local Storage. You should see these files there:

    file__0.localstorage
    file__0.localstorage-journal
    https_public-cdn.cloud.unity3d.com_0.localstorage
    https_public-cdn.cloud.unity3d.com_0.localstorage-journal


    That's All.
    Thanks,
    Miles
     
unityunity