Search Unity

Cloth Acceleration Not Working

Discussion in 'Physics' started by alti, Aug 9, 2019.

  1. alti

    alti

    Joined:
    Jan 8, 2014
    Posts:
    21
    Is it just me, or is the random/external acceleration feature no longer working for cloth in Unity 2019.2?

    I can't get it to work on a skinned mesh or even a normal plane. Nothing happens no matter how much I crank up the values. I've even played with the values in the Physics settings, and nothing changes the cloth's velocity to simulate wind.

    Does anybody know if the feature is discontinued or something?
     
    ElasticSea likes this.
  2. alti

    alti

    Joined:
    Jan 8, 2014
    Posts:
    21
    anybody?
     
  3. AndrewRH

    AndrewRH

    Joined:
    Jan 24, 2012
    Posts:
    2,608
    I think I read on another forum / bug posting..someone else reported this.. I think it might be a regression bug.
     
    alti likes this.
  4. SomeGuy22

    SomeGuy22

    Joined:
    Jun 3, 2011
    Posts:
    513
    There is a regression bug in which the gravity for cloths seems to be set to some random point of the world instead of down. I believe this is the issue tracker for it, but I haven't seen any other updates. It's reproducible with just a standard plane in 2019.2, with all the default settings. You'll see that it goes flying and basically ignores external accel from the Cloth component options. I talked about it some more here. Vote on the issue tracker link if you can, because this basically renders cloth unusable for me and I'd like to have it set up as soon as possible...
     
    Zombietron, alti and ElasticSea like this.
  5. alti

    alti

    Joined:
    Jan 8, 2014
    Posts:
    21
    I voted on it. I hope they fix this soon. I have characters that power up with cloth on them, so it looks weird now that the cloth doesn't do anything. weird that my 2018 version tackled this just fine, but suddenly it's not a feature.