Search Unity

  1. Unity 2018.1 has arrived! Read about it here
    Dismiss Notice
  2. Scriptable Render Pipeline improvements, Texture Mipmap Streaming, and more! Check out what we have in store for you in the 2018.2 Beta.
    Dismiss Notice
  3. If you couldn't join the live stream, take a peek at what you missed.
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Learn more.
    Dismiss Notice
  5. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  6. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Classes/Unity/UnityInterface.h:187:1: unknown type name 'bool'

Discussion in 'Unity Cloud Build' started by SniperED007, Jun 8, 2018.

  1. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    68
    Description of issue:
    Cloud build for iOS fails (Android builds without issue)

    Unity version:
    2018.1.3f1

    XCode version:
    Building with Xcode 9.3

    Relevant plugins being used:
    Facebook

    Project name:
    GreedCity

    Build log (relevant chunk):
    225: + Building with Xcode 9.3
    226: ▸ ❌; /BUILD_PATH/lighthouse-games-studio.greedcity.default-ios/temp.XXXXXX20180608-4383-crtd07/Classes/Unity/UnityInterface.h:187:1: unknown type name 'bool'
    227: ❌; /BUILD_PATH/lighthouse-games-studio.greedcity.default-ios/temp.XXXXXX20180608-4383-crtd07/Classes/Unity/UnityInterface.h:187:1: unknown type name 'bool'
    228: fastlane finished with errors
    229: /BUILD_PATH/.mason/buildpacks/xcode/bin/compile:253:in `block in build': ! xcode build failed. (RuntimeError)
    230: ! build of 'default-ios' failed. compile failed
    231: publishing finished successfully.
    232: Finished: FAILURE
     
  2. ollieblanks

    ollieblanks

    Unity Technologies

    Joined:
    Aug 21, 2017
    Posts:
    24
    Thank you for reporting this.

    This has already been resolved in the alpha version of 2018.3 (which doesn't really help you immediately, but suggests a fix is imminent) and the fix has been logged to be included in 2018.1 and 2018.2.

    Unfortunately, there is not a workaround I can suggest for use with Cloud Build at this time, I will be pushing for a quick fix and keep you informed of updates.
     
  3. eladleb4

    eladleb4

    Joined:
    Apr 25, 2016
    Posts:
    7
  4. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    68
    Any news on when this fix is coming?
     
  5. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    68
    "(which doesn't really help you immediately, but suggests a fix is imminent)"

    Still waiting for a fix or an update on the situation.... Cloud builds haven't worked since launching 2018.1.
    Getting really annoyed with this service.