Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  4. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Cinemachine jittering when following vehicle

Discussion in 'Cinemachine' started by derkoi, Sep 7, 2018.

  1. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    1,891
    Hey all,

    I have a Edy's vehicle physics car that I want Cinemachine to follow, all is working well apart from this horrible jitter.



    Any ideas what's going on and how I can get rid of it?

    Thanks
     
  2. user099

    user099

    Joined:
    May 29, 2015
    Posts:
    21
    i think this happens with rigidbody interpolation and "fixed update" of cinemachine. try to change rigidbody interpolation to none or change cinemachine to "late update"
     
  3. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    1,891
    Thanks, tried both but it made little difference. :(
     
  4. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,532
    1. What version of CM
    2. What is the Brain's update mode?
    3. Does the car have rigidbody Interpolation?
    4. Can you show a picture of the vcam inspector?
     
  5. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    1,891
    1. v2.2.7
    2. Tried all of them but LateUpdate seems to be the best (as seen in the video)
    3. Yes but I've also tried none and Extrapolate with no difference.
    4. Sure:
    Cinemachine Vcam Settings.png

    Interestingly it's not as bad when the game is built on device but it's making me feel quite ill working with it for hours in the editor. :(
     
  6. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,532
    As a diagnostic: do you still get jitter if you switch the Brain to FixedUpdate and turn off interpolation?
     
  7. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    1,891
    I switched off interpolation & set the brain to FixedUpdate. It cured the jitter but made the car wheels jump and flicker so I switched them to be less accurate in the Edy's settings which seems to have stopped them jittering but I'm not sure on other repercussions of turning off interpolation on Edys.

    As a side note with this set up, the noise I have on the camera is no longer smooth, it's all jittery.
     
  8. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,532
    ok great. There is one more experiment you can try.
    Restore the car to Interpolate, and put the brain back in Smart Update.
    There is a CM 2.2.8 preview release that has been enhanced with an experimental damping algorithm designed to address camera jitter that sometimes occurs with Interpolated RigidBodies.
    If you're game to try it, have a look at this thread: https://forum.unity.com/threads/rig...ng-damping-on-transposer.535548/#post-3638500
     
    derkoi likes this.
  9. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    1,891
    Thanks, I'll give that a try
     
  10. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    1,891
    Tried that and it seems to be working great!

    Thanks for your help!
     
    Adam_Myhill likes this.