Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Let us know a bit about your interests, and if you'd like to become more directly involved. Take our survey!
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Cinemachine Collider and Blend Issues

Discussion in 'Cinemachine' started by Wolf_Bane, Oct 11, 2018.

  1. Wolf_Bane

    Wolf_Bane

    Joined:
    May 12, 2015
    Posts:
    1
    Currently working on a project where we have a single model that is being showcased on a turntable with multiple virtual cameras (from 3 different angles, namely Top-down with UI overlay, left, and right) placed to look at 6 different points of interest on the model, and we just turn off and on the correct virtual camera based on an enumerator ID and let the CM Brain handle blend given a pre-defined CinemachineBlenderSettings.

    The issue we're running into is that the blends will often clip through the model, despite the model having collision volumes (correctly layered and everything). Given some research, it seems like blending between cameras doesn't calculate collision, so I am at somewhat of a loss. I considered a ClearShot camera to find the most 'matching' child virtual camera (among the preset POV virtual cameras) and just blend to that one, but I am unsure. Any help is greatly appreciated.
     
  2. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,637
    You can give hints to the blender for interpolating the camera positions. By default, it's a linear blend which may bring the camera through the model. Try using cylindrical position. Set it for all the vcams.

    upload_2018-10-15_12-44-55.png