Search Unity

  1. Unity 2019.1 beta is now available.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We're looking for insight from anyone who has experience with game testing to help us better Unity. Take our survey here. If chosen to participate you'll be entered into a sweepstake to win an Amazon gift card.
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Unity 2018.3 is now released.
    Dismiss Notice
  6. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Character not in T-pose when importing animation

Discussion in 'Animation' started by ThreeRing, Dec 7, 2018.

  1. ThreeRing

    ThreeRing

    Joined:
    Aug 24, 2016
    Posts:
    10
    Hello everyone,

    I'm having a problem in Unity 2018.2.15f1 (64-bit) when importing animations.
    After dragging an animation to my project, setting it to Humanoid, and Root Transform, the avatar gives me a warning saying "Character is not in T-pose". I have searched online and got to the point where it gets fixed by pressing the Enforce T-pose button down below, but I have quite a huge number of animations, and doing this step for every one of them is quite time-consuming.

    On previous versions I don't remember having a problem like this and in fact it's my first time doing this procedure to fix it. Is it some kind of bug that came up on this version, or might I be doing something wrong?

    Thank you in advance for your help.
     
  2. leftshoe18

    leftshoe18

    Joined:
    Jul 29, 2017
    Posts:
    34
    Did you get the animations from a site or did you make them yourself?
     
    ThreeRing likes this.
  3. ThreeRing

    ThreeRing

    Joined:
    Aug 24, 2016
    Posts:
    10
    Apologies for the delay in replying.

    I made the animations myself.
     
  4. ThreeRing

    ThreeRing

    Joined:
    Aug 24, 2016
    Posts:
    10
    Just checking in again to ask if you guys can give some advice on this, as I still have not found a suitable fix for it :(
    Thanks in advance!
     
  5. leftshoe18

    leftshoe18

    Joined:
    Jul 29, 2017
    Posts:
    34
    On the rig import try copying the avatar from another model instead of creating a new one for the animation. If it works you should only have to set up one avatar and enforce t-pose on that if necessary.
     
  6. ThreeRing

    ThreeRing

    Joined:
    Aug 24, 2016
    Posts:
    10
    Thank you for your reply and suggestion.
    In fact, I have already done that, and yes, it works. However, I need to do it to every single FBX file that I import.
    In Unity's previous versions, just bringing the FBX in wouldn't cause a problem at all, but in this Unity2018.2.15f1 version, when changing the animation setting to Humanoid, it just says there is no T-Pose... (again, this can be fixed through the method you said, but I need to do it to all the files one by one).

    Is there any reason for this to happen? Is there a fix?

    Once again, thanks in advance for your attention!
     
  7. ThreeRing

    ThreeRing

    Joined:
    Aug 24, 2016
    Posts:
    10
    I guess there is no fix?...
     
  8. ikazrima

    ikazrima

    Joined:
    Feb 11, 2014
    Posts:
    257
    @ThreeRing not sure why you need to set enforce tpose for every animation, you just need to do it once and copy them.

    A) Import a t-posed FBX without animation, set it to humanoid / enforce t-pose. This will be the main file you'll be using.
    B) Import other FBXs with armature & animation ONLY (without mesh).

    Select all files in B), set it to humanoid, set copy rig from A.
     
  9. petersx

    petersx

    Joined:
    Mar 5, 2015
    Posts:
    202
    I have the same problem - when importing animation f.e. from mixamo and set enforce t-pose - animation is bad - walk animation looks like it be zombie, not human.
    It's a pity, because Unity autorig module was the best - it was: drag & drop & fun - but now it's more like: drag & drop & horror
     
  10. ThreeRing

    ThreeRing

    Joined:
    Aug 24, 2016
    Posts:
    10
    Thank you for your reply!

    I will try this method and get back to you if something goes wrong!
     
    ikazrima likes this.