Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Changing Unity default background colour.

Discussion in 'Editor & General Support' started by Digital Shock, Aug 27, 2013.

  1. Digital Shock

    Digital Shock

    Joined:
    Jan 23, 2013
    Posts:
    12
    Hi there,

    Been trying to search online on how to change unity default background colour from blue to black. i don't want to do a skybox, just want straight colour to change. can anyone help me?
     
    RPLaine likes this.
  2. Jack Thomas

    Jack Thomas

    Joined:
    Jun 26, 2013
    Posts:
    34
    Its not Unity's background colour, just the default colour your camera sees when no objects are being rendered. Go to your scenes camera and change the background colour picker in the inspector. You can also change clear flags too 'Solid Color', or use a skybox material using the same texture.
     
    Last edited: Aug 28, 2013
  3. Wordsonplay

    Wordsonplay

    Joined:
    Apr 29, 2013
    Posts:
    16
    I agree. The first thing I do on creating a new scene is to change the camera background to black. That sky blue really irritates me. If you find a solution to this, please share it!
     
    ElnuDev likes this.
  4. RTSeegrist

    RTSeegrist

    Joined:
    Sep 14, 2014
    Posts:
    1
    Edit Menu > Preferences... > Colors > Change the background color under the Scene heading.

    This changes the background of the #Scene editor. Click on Main Camera in the Hierarchy to change the background color for when you press Play.
     
    Last edited: Sep 14, 2014
    Lukebox, HernandoNJ, rgudino and 9 others like this.
  5. kodagames

    kodagames

    Joined:
    Jul 8, 2009
    Posts:
    546
    In Unity 5.1.2.1f on a mac I goto Unity>Preferences>Colors then under scene I changed the background color but in the scene view there is still the skybox looking view (or background). Is there a another way to change this? (Its pretty horrible looking...)

    The game scene is simple Clear Flags: Solid Color.
     
    mendi80 and Soluble_Fish like this.
  6. behzadha

    behzadha

    Joined:
    Nov 23, 2015
    Posts:
    1
    This is what I know but on Windows. Maybe helps you too!
    Two things need to do:
    1- On the scene panel uncheck the Skybox
    2- Click on the camera then in the Inspector, change the clear flag to Solid color

    a1.jpg a2.jpg
     
    abj87, Sab_Rango, p4rse and 10 others like this.
  7. LordRyuga

    LordRyuga

    Joined:
    Sep 21, 2020
    Posts:
    1
    THANKS A LOT, This helped me a lot. I wanted red text but the background made it really irritating. THANKS
     
unityunity