Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Bug CCD and Addressables are incompatible?

Discussion in 'Unity Cloud Content Delivery' started by goal2112, Jul 26, 2022.

  1. goal2112

    goal2112

    Joined:
    May 8, 2013
    Posts:
    8
    Is there any reason Addressables (1.19.19) won't work with CCD 2.2.0?
    Is it only compatible with the older 1.0.0-pre.2 version?
    Where is this documented? Is there any way to get this to work?

    image (6).png
     
  2. DevinLFL

    DevinLFL

    Joined:
    Nov 5, 2021
    Posts:
    10
    Oof running into this issue as well, it feels really weird to roll with a pre-release version for a released package
     
  3. Unity_JonathanCl

    Unity_JonathanCl

    Unity Technologies

    Joined:
    Feb 24, 2022
    Posts:
    15
    Hi goal2112,

    Thank you for your question. Yes, it is possible that some version of the addressable packages works with a specific version of the CCD package for the integration between the two to be possible. We are sorry for the inconvenience and are working on documenting this problem and making it easier to manage.

    Best,
    JC
     
  4. goal2112

    goal2112

    Joined:
    May 8, 2013
    Posts:
    8
    Hi JC, thank you for your reply.

    Would you be able to get me more specific information, though? It appears like the addressables package only uses an extremely old version, a pre-release version, one that seems to be significantly behind.

    Current version: 2.1.0
    Addressables supported version: 1.0.0-pre.2

    Does it make sense that the Addressables package would only use a version that outdated?

    Also, I should note that the description for the CCD Management package itself states it is in use by the Addressables package. Isn't that in direct contradiction to what you just said, and to what I've shown in my screenshot? Why is that?


    Thank you,
    - Jonny.
     
  5. DevinLFL

    DevinLFL

    Joined:
    Nov 5, 2021
    Posts:
    10
    It would be ideal if the supported version was at the very least a release and not a pre-release. We'd love to be able to use the latest CCD package and the native integration rather than rolling our own custom pipeline if possible. It's a bit frustrating that these two released services are incompatible.Is there any timeline on this update / fix?
     
  6. Unity_JonathanCl

    Unity_JonathanCl

    Unity Technologies

    Joined:
    Feb 24, 2022
    Posts:
    15
    Hi,

    Sorry for the confusion, here are the compatible versions between CCD and Addressable, hope that this can help until it is documented.

    upload_2022-8-1_15-55-31.png

    Best,
    JC
     
  7. goal2112

    goal2112

    Joined:
    May 8, 2013
    Posts:
    8
    It looks like versions 1.20.+ aren't out yet (or are themselves only in pre-release form)?
     
  8. Unity_JonathanCl

    Unity_JonathanCl

    Unity Technologies

    Joined:
    Feb 24, 2022
    Posts:
    15
  9. DevinLFL

    DevinLFL

    Joined:
    Nov 5, 2021
    Posts:
    10
    Yeah, unfortunately I'm not able to select 1.20 as a package version in unity 2021.3.7f1. I just took a look at 2022.1.11f1 and it does look like I would be able to use addressables 1.20.3 there. According to the table above it should be supported in 2019.4+. Is there some way to manually target the newer release of addressables or would y'all able to look into why the newer version of the package isn't showing up in the LTS release of 2021?
     
  10. DevinLFL

    DevinLFL

    Joined:
    Nov 5, 2021
    Posts:
    10
    upload_2022-8-1_11-40-18.png

    It looks like 1.20.3 is compatible but how would I get that version of the package in 2021.3 if the package manager GUI doesn't present that version as an option?
     
  11. goal2112

    goal2112

    Joined:
    May 8, 2013
    Posts:
    8
    Updating the version manually in the packages manifest appears to work!
    upload_2022-8-1_17-35-28.png
     
    SebT_Unity likes this.