Search Unity

  1. Unity Asset Manager is now available in public beta. Try it out now and join the conversation here in the forums.
    Dismiss Notice

(Case 1089149) [Polybrush] Failed to paint vertex color

Discussion in '2018.3 Beta' started by optimise, Oct 9, 2018.

  1. optimise

    optimise

    Joined:
    Jan 22, 2014
    Posts:
    2,129
    I try to paint the ground but nothing happen. What I expect is when I paint the ground it should at least change the color.

    Actual result
    polybrush.png


    Expected result
    upload_2018-10-9_22-12-51.png
     
    LeonhardP likes this.
  2. hippocoder

    hippocoder

    Digital Ape

    Joined:
    Apr 11, 2010
    Posts:
    29,723
    upload_2018-10-11_1-1-20.png

    So, probably the vert cols are being stripped on import or the shader isn't supporting vert colours. Or maybe it's just all Unity's fault (blame LeonhardP) :D
     
  3. poa123

    poa123

    Joined:
    Jul 13, 2018
    Posts:
    22
    I have a problem with Vertex Color paint on Polybrush too.
    I have a material with a shader configured using Shader Graph (HD Pipe) to use Vertex Color (simple Lerp between two color in the R channel)... when i paint the same message appears and the object become all black... sometimes it works for some seconds, and then go black again.
    I think Vertex Color Paint is not reliable at the moment... at least using shader graph shaders.
     
  4. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    3,136
    Could you submit a bug report for this issue please :)