Search Unity

capped to 30fps on Surface RT

Discussion in 'Windows' started by stationx, Sep 21, 2013.

  1. stationx

    stationx

    Joined:
    Jul 9, 2012
    Posts:
    251
    Hello,
    I have got a new question. Somehow, the Surface RT keeps running my game on 30fps. Even if I have application.targetframerate set to 60. I also, don't notice any attempts to get higher then 30fps. Is there some hidden safe catch in Unity that keeps the game running at 30fps?
     
  2. dark_nanos

    dark_nanos

    Joined:
    Sep 19, 2013
    Posts:
    4
    Hi. The only thing I can think of that would cause that is having VSync on. Check Edit>Project Settings>Quality and see what the VSync Count is set at.
     
  3. stationx

    stationx

    Joined:
    Jul 9, 2012
    Posts:
    251
    At the moment: Every VBlank. What should be the correct value?
     
  4. dark_nanos

    dark_nanos

    Joined:
    Sep 19, 2013
    Posts:
    4
    Set it to "Don't Sync" if you want to be able to go over the 30 FPS. But sometimes this can change the speed of things in your game and speed them up a lot if the frame rate goes too high.
     
  5. stationx

    stationx

    Joined:
    Jul 9, 2012
    Posts:
    251
    thnx! I'll give that a try. But I guess, those default settings has been set for a reason. ;-)

    update: didn't work, framerate got even worse. Beside, I figured out, I really need to remove some unnecessary stuff to increase performance.
     
    Last edited: Sep 24, 2013
  6. dark_nanos

    dark_nanos

    Joined:
    Sep 19, 2013
    Posts:
    4
    No problem, sorry to hear it didn't work. Ya, may need to remove some stuff. I'm excited about the new Surface tablets! Already have both the first ones. The new RT version should have much better performance with the Tegra 4 :)