Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question Can't use a namespace in a script from the FPS Micro-Game

Discussion in 'Getting Started' started by Dvilches, Oct 13, 2021.

  1. Dvilches

    Dvilches

    Joined:
    Aug 18, 2019
    Posts:
    1
    Hi everyone!
    So i created and imported a package from another project to the FPS micro-game. I tried to call the namespace of the package from a script from the microgame, but it didn't catch the difference. To test i created another c# class and put it outside the folder, and there i could call the namespace, but if a move it to folder i could not.


    upload_2021-10-13_14-15-52.png

    In red is where i located the scripts from the package. In blue, is the folder with the scripts i'm tring to modify, to which i need to use the "MovingHud" namespace but i can't. And in green is the test class where i tried to call the namespace succesfully.

    What can i do to use the MovingHud scripts from the Gameplay folder??
    And by the way, what does the cubes on those folders mean??