Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. We are looking for feedback on the experimental Unity Safe Mode which is aiming to help you resolve compilation errors faster during project startup.
    Dismiss Notice
  3. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Can't turn on intellisense in visual studio for Unity (ubuntu 18.04)

Discussion in 'Linux Editor' started by sonoron, Sep 30, 2019.

  1. sonoron

    sonoron

    Joined:
    Jun 23, 2019
    Posts:
    1
    I set visual studio code as an external script editor, but i can't use intellisense when I work with scripts.
    screenshot.png
    In this exemple i want to write "Rigitbody2D."
    screenshot_1.png
    In this exemple i want to write "monster = GetComponent<Rigidbody2D>();"
    screenshot_2.png
    As you can see i can't use intellisense in my unity code.

    How I can fix this?
     
  2. xJalal_AZ

    xJalal_AZ

    Joined:
    Jul 24, 2020
    Posts:
    1
    Hi, i have the same issue, please let me know if you fixed it, Thanks.
     
  3. MadWatch

    MadWatch

    Joined:
    May 26, 2016
    Posts:
    44
    - Do NOT install VS Code from Flatpak (last time I checked it didn't work with Omnisharp).

    - Install the .NET SDK and runtime from here (select the Ubuntu version you're using).

    - Install the C# extension into VS Code.

    - Select VS Code as your external script editor into Unity's settings (you might have to put the path manually if Unity doesn't find it).

    - Open your project into Unity. From the Assets menu, select Open C# Project. This will launch VS Code and you should have intellisense working.
     
  4. xAdamQ

    xAdamQ

    Joined:
    Jul 23, 2016
    Posts:
    5
    Don't forget to Add "Visual Studio Code" plugin from the package manager as well.
    And remove vs code generated files
     
unityunity