Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Question Can't select vs code in Preference - Extenral Tools in Unity

Discussion in 'Code Editors & IDEs' started by kotraner, Mar 15, 2022.

  1. kotraner

    kotraner

    Joined:
    Dec 5, 2017
    Posts:
    11
    On preference - External Tools I have option only for
    Open by file extension , Visual studio , then browse.

    to choose Vscode, I chose browse , then I go to where Vscode is. but it grayed out so I can't select it.
    how can I select vscode for external script editor...?
    my version is 2020.3.29f1
     
  2. DanVioletSagmiller

    DanVioletSagmiller

    Joined:
    Aug 26, 2010
    Posts:
    205
    Check your Package Manager to make sure you have the VS Code Editor option. It might be uninstalled or on an older version.
    upload_2022-3-18_10-54-19.png
    If this doesn't solve it, I'm not sure how else to help. Maybe check the VSCode installer or package manager for a Unity addon of some type. I'm typically on VS directly, so I don't think I'd be able to offer more advice if that doesn't work.
     
    yokoaiii, TimPham and kakasss like this.
  3. TimPham

    TimPham

    Joined:
    Sep 22, 2020
    Posts:
    5
    This solved my problem. Thank you very much ^_^