Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Can't select objects in scene view

Discussion in 'Editor & General Support' started by willemsenzo, Dec 18, 2012.

  1. willemsenzo

    willemsenzo

    Joined:
    Nov 15, 2012
    Posts:
    576
    Yesterday I installed Unity 3.5.7 free version. It seems I'm not able to select objects in the scene view by just clicking on them. When I click and drag the mouse it selects the object, but its very hard to select specific child objects this way. I know I can go through the hierarchy and select the object in there but that's not the workflow I'm after.

    On my hunt for a solution I haven't got any luck so far. I searched for information on this issue, but either there is no answer, or people recommend to reinstall Unity which in my opinion is a bit too harsh for something like this. There is no guarantee anyway that this will solve the problem. I'm sure there must be some workaround or there is something I'm overlooking. I hope someone can help me on this, and if not then ofcourse there still is the brute force option of a new installation.

    Thanks for reading this :)
     
  2. ksam2

    ksam2

    Joined:
    Apr 28, 2012
    Posts:
    1,042
    Hi I have same issue in Unity 5.2.0 b4
    Please help
     
  3. ArachnidAnimal

    ArachnidAnimal

    Joined:
    Mar 3, 2015
    Posts:
    1,698
    I have had this issue for many releases of Unity so far. So far it has happened about 20 times today. It selects objects behind the object which I am trying to select. When I close Unity and re-open I can then select the game object again. I guess Unity cannot reproduce this issue. But it is very annoying. I have to start disabling items behind the current items I am working on.
     
  4. ksam2

    ksam2

    Joined:
    Apr 28, 2012
    Posts:
    1,042
    Re docking scene windows will solve this issue
     
    ArachnidAnimal likes this.
  5. ArachnidAnimal

    ArachnidAnimal

    Joined:
    Mar 3, 2015
    Posts:
    1,698
    Ok, I'll try that the next time this starts happening.
     
  6. ksam2

    ksam2

    Joined:
    Apr 28, 2012
    Posts:
    1,042
    Sorry but this solution was for my problem (I couldn't select anything). after docking scene windows solved. but don't know about you're issue
     
  7. bocs

    bocs

    Joined:
    May 9, 2009
    Posts:
    357
    Last edited: Sep 7, 2015
    ArachnidAnimal likes this.
  8. TUNev

    TUNev

    Joined:
    May 7, 2016
    Posts:
    2
    This is ridiculous. -- Unity, please fix. I have the same problem, and I have tried everything that has been suggested. I am having to look through every rock in my project and guess randomly until I get it right which rock it is I want to move.
     
  9. TUNev

    TUNev

    Joined:
    May 7, 2016
    Posts:
    2
    It won't even let me select ANYTHING
     
  10. prossouw

    prossouw

    Joined:
    May 28, 2016
    Posts:
    1
    This is happening to me too.. constantly..
     
  11. ksam2

    ksam2

    Joined:
    Apr 28, 2012
    Posts:
    1,042
    Closing scene view windows and docking it again doesn't solved your problem?
     
  12. DPiddy

    DPiddy

    Joined:
    Jun 24, 2016
    Posts:
    1
    Hello,

    This is happening to me as well.
    Closing/opening new Scene tabs does not fix this issue.
     
  13. paulblue

    paulblue

    Joined:
    May 5, 2015
    Posts:
    1
    I am also having this issue. Creating a new scene works, except I have a lot of work put into the old scene. Changing the scene tab, closing it, restarting Unity, restarting my computer, nothing works. Once every 100 clicks while encountering this issue I may be able to click an object, then I click again and I am not able to select again.

    Edit:
    Found finally in the middle of this Thread:
    https://issuetracker.unity3d.com/is...ects-in-scene-view-without-dragging-around-it
    Comment out/Delete the Code [ExecuteInEditMode]
    Water is not visible in edit more, but it works now.
     
  14. cooperm211

    cooperm211

    Joined:
    Nov 23, 2012
    Posts:
    3
    I've also had this issue before (when it still doesn't come back after reloading the scene tab) and disabling the water did fix it. It's somehow like blocking clicks in the scene view.
     
  15. tobiasforsling

    tobiasforsling

    Joined:
    Jul 25, 2016
    Posts:
    1
    Had the same problem working on our game! Sooooo frustrating! (Version 5.3.4f1)
    Found a guy who had a solution that in fact DID work! Quoted below!

    "Oxeren

    Apr 01, 2016 09:46



    Had the same issue after updating to 5.3.4, as people are saying it was caused by water reflections. The solution that does not include changing water type is to remove [ExecuteInEditMode] line from the water script, though there will be no reflections in the scene view."
     
  16. Cascho01

    Cascho01

    Joined:
    Mar 19, 2010
    Posts:
    1,199
    Confirmed
     
  17. Corpano

    Corpano

    Joined:
    Feb 5, 2017
    Posts:
    4
    Hi.
    I`ve found some other solution that worked for me...
    Try to go to Layers and uncheck all Lock Layer for Picking for Default,TransparentFX....I`m using 5.5 Unity version.
    Hope It will work for you :)
     
    Chosenator and honor0102 like this.
  18. honor0102

    honor0102

    Joined:
    Jan 30, 2019
    Posts:
    4
    That's my solution! thanks
     
  19. michaelday008

    michaelday008

    Joined:
    Mar 29, 2019
    Posts:
    43
    For those having issues with this:
    In 2019.8.f1 I could not select anything in scene view. I clicked the "Layers" dropdown (which is located *under* the menu bar near the mimimize/close/maximize window controls at the top right of the editor.
    After clicking the lock beside "walkable" I could select objects again.
     
    roshan090 likes this.
  20. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    8,153
    This worked for me, although I didn't have a "walkable" layer, for me it was the default UI layer
     
  21. shmlalex

    shmlalex

    Joined:
    Oct 20, 2019
    Posts:
    1
     
  22. roshan090

    roshan090

    Joined:
    Mar 20, 2018
    Posts:
    30
    This worked for me
     
    Chosenator likes this.
  23. HernandoNJ

    HernandoNJ

    Joined:
    May 13, 2018
    Posts:
    10
  24. dblqt

    dblqt

    Joined:
    Jun 29, 2020
    Posts:
    1
    Maybe stating the obvious but there is a gutter in the hierarchy window/tab where the visible and selectable property of each and every object can be set:
    upload_2020-6-29_16-1-46.png
     
  25. jessesloan1

    jessesloan1

    Joined:
    Apr 9, 2014
    Posts:
    2
    I locked and unlocked every layer. No joy. I used the gutter mentioned by dblqt above. No joy. The only thing that worked for me was to close Unity and restart it.

    I wish they would refine the interface some. It would be nice to be able to disable selection of children but still be able to select the parent. For example i have a crate i made from several parts. They are all children an empty gameobject. If I disable selection (in the gutter) of all the child objects it automagically disables selection of the parent object. If anyone knows how to change this it would be awesome. I want to be able to point at the screen, click and ONLY select the parent. As it is if you point and click you are very like to select one of the children. Very annoying.
     
  26. ammarbuthani

    ammarbuthani

    Joined:
    Sep 6, 2020
    Posts:
    1
    upload_2020-9-7_22-20-4.png

    Had the same issue in 2020, solved by hitting W or clicking on that arrows instead of the hand
     
unityunity