Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Can't seems to get over 60 fps with the new HDRP

Discussion in 'Graphics Experimental Previews' started by noamro, Dec 7, 2019.

  1. noamro

    noamro

    Joined:
    Dec 28, 2017
    Posts:
    16
    I don't know why, but when I add light and shadows to even the most basic scene (on fullscreen) I'm circling around 30-60 fps, and that's a very simple scene, what happens if I add HDRP to a fully made game?
    am I doing something wrong?

    I took the same scene and with the built-in standard pipeline i got 300 fps (full screen as well) and with the HDRP it's between 30-60
     
  2. Olmi

    Olmi

    Joined:
    Nov 29, 2012
    Posts:
    1,553
    It might be that your system is not powerful enough?

    And it's hard to guess what you have configured in your HDRP asset. But If you crank up all the settings it might run that fast. Are you sure you don't have anything else going on.

    Also check your resource usage in your system. If you happen to be on windows, check Task Manager (ctrl-alt-del) and see check processes, enable GPU column if you don't have it active. If that GPU percentage is high for Unity, it might be that it's just a bit too taxing for your GPU...

    One more tip - toggle off Animated textures in your editor view - that seems (at least on some configurations) waste a lot of GPU time. Someone pointed out this out a few days ago and I had this same issue too. Idle scene consumes sometimes 50-75% GPU time, and you toggle of that animated textures in scene view, GPU usage drops radically.

    P.S. you didn't mention which Unity version and which HDRP version you are using.
     
  3. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    11,988
    What GPU have you got?
     
  4. noamro

    noamro

    Joined:
    Dec 28, 2017
    Posts:
    16
    I got gtx 1060 and an i7-8700
    I'm tried it on 2019.1, and 2019.3 with the 7.1.5 / 7.1.6 HDRP
    same results and i got nothing turned on, same results even after building the game and playing a standalone version..

    I'm trying to fix it in the past three days, trust me I've been through all the settings :\
     
  5. Olmi

    Olmi

    Joined:
    Nov 29, 2012
    Posts:
    1,553
    Well. If you brought in old HDRP stuff from earlier Unity version, try deleting your HDRP asset and create new one. Also try to reset other settings in your project too like those HDRP graphics settings (if possible), just to see if there's something under the cover that is somehow configured wrong.
     
  6. noamro

    noamro

    Joined:
    Dec 28, 2017
    Posts:
    16
    I also tried it in a fresh project... same results.
    and I tried to use the default HDRP configuration and disabling vsync of course.
    The problem happens what u add a light with shadow into the scene. immediately loses like 100 fps, and every time u add another point light u lose about 30 fps aswell.
     
  7. Grimreaper358

    Grimreaper358

    Joined:
    Apr 8, 2013
    Posts:
    789
    Create a build.
    The editor's performance is way lower than what it will give you in a build.
     
  8. noamro

    noamro

    Joined:
    Dec 28, 2017
    Posts:
    16
    I did, same result
     
  9. interpol_kun

    interpol_kun

    Joined:
    Jul 28, 2016
    Posts:
    134
    Are the settings in HDRP identical to legacy (in terms of light, shadows, PP and stuff)?

    If they are not so there is nothing to compare. Builtin and HDRP are very different out of the box.
     
  10. Grimreaper358

    Grimreaper358

    Joined:
    Apr 8, 2013
    Posts:
    789
    Wait actually I think I know what's the problem. You probably have VSync on.
    - For builds disable Vsync in the Quality Settings
    - Additionally in the editor disable VSync in the game view if it is on. (If VSync is enabled in the quality settings or not, if it is on in the game view settings it will limit the FPS in the game view)

    Vsync in Quality Settings - This I the first thing I touch on any new project.
    upload_2019-12-7_23-23-30.png


    Vsync in the Game View
    upload_2019-12-7_23-26-51.png
     
  11. noamro

    noamro

    Joined:
    Dec 28, 2017
    Posts:
    16
    I don't have vsync on :\
    not in the build or in the game view.
     
  12. noamro

    noamro

    Joined:
    Dec 28, 2017
    Posts:
    16
    I don't understand the question.
    I tried all of the HDRP settings, believe me.
     
  13. interpol_kun

    interpol_kun

    Joined:
    Jul 28, 2016
    Posts:
    134
    The question is simple. Did you match the Legacy settings in HDRP, or you just created 2 projects and measured their performance? In HDRP there are a lot of stuff you have to turn off if you want to match legacy out-of-the-box look.

    HDRP will be slower, afaik it has lot's of demanding stuff (won't mention URP being slower too btw) in comparison to legacy.