Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  4. Nominations have been announced for this years Unity Awards. Celebrate the wonderful projects made by your peers this year and get voting! Vote here!
    Dismiss Notice
  5. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  6. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Can't Orbit Around Focused GameObject

Discussion in 'Linux Editor' started by sfoust, Jun 13, 2016.

  1. sfoust

    sfoust

    Joined:
    May 18, 2011
    Posts:
    22
    Sorry if this is obvious, or if I'm just doing it wrong, but I can't figure out how to get the Linux build (build 5.3.5 running in Ubuntu) to orbit around a focused game object. On pressing 'F' the editor cam zooms to the object just fine, but holding ALT and the Right-Drag seems to open a popup menu instead of orbiting behavior I was expecting (my muscle memory says this is proper key combination to Orbit around a selected object in the Windows editor). Right-Drag alone rotates the camera around the editor camera pivot just fine. Also, ALT W,A,S,D seems to fly around the scene as expected.

    Dose the Linux version of Unity Editor have a different key combination for Orbiting from the Windows version?
     
  2. LukaKotar

    LukaKotar

    Joined:
    Sep 25, 2011
    Posts:
    375
    You have to change a setting in your operating system. By default, alt + left mouse button is used to move a window by dragging your mouse. It also seems to affect the right mouse button, for some reason.
    1. Install CompizConfig Settings Manager (sudo apt-get install compizconfig-settings-manager) and open it.
    2. You'll find "Move Window" somewhere at the bottom. Click it.
    3. Change the "Initiate Window Move" option. (I have mine on control+alt+button1)
     
    sfoust likes this.
  3. sfoust

    sfoust

    Joined:
    May 18, 2011
    Posts:
    22
  4. bigobangux

    bigobangux

    Joined:
    Jun 30, 2017
    Posts:
    3
    By the way I wonder if there is a way to bind camera orbiting in editor to a key combination? Thank you.
     
  5. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    935
    Not currently - there's some upcoming work to vastly improve shortcuts/rebinding/etc.
     
    kmare likes this.