Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug Can't migrate from 2019.3.13f1 to 2019.4.40f1

Discussion in 'Editor & General Support' started by ScaryRobotGames, Jun 14, 2020.

  1. ScaryRobotGames


    May 2, 2007
    Tried updating my project from 2019.3.13f1 up to 2019.4.40f1 but it crashes some point during the upgrade process. Tried it multiple times.

    I filed a bug report and got a quick response that versions of Unity before 2019.3 isn't supported and that I should try upgrading. And then the ticket was then closed. Um, okay. Not helpful on multiple levels.
  2. Skuxlife


    Nov 27, 2016
    Bumping this. Pretty similar issue where I can't migrate from 2019.3.7 to 2019.4 LTS.
  3. mkgame


    Feb 24, 2014
    Hi, check your logs, example path: "AppData\Local\Temp\Unity\Editor\Crashes\Crash_2020-06-19_083348619". In this folder open the "Editor.log" file and scroll to the bottom. There is a backtrace, and look for the asset name caused the crash. Then update the asset in a second project and replace the updated asset in your main project. Maybe you have to remove the asset from your project, if no update is available. Always make a backup!

    You can also have a stacktrace like the following one. There you can see the Camera. In this case try to disable the camera effects scripts, especially the non Unity ones. But this then, if you crash in the Editor, after you can open it.

    Code (CSharp):
    1. 0x00007FF79349F063 (Unity) Shader::GetLocalKeywordRemap
    2. 0x00007FF792339293 (Unity) ShaderLab::Pass::ApplyPass
    3. 0x00007FF7922F8393 (Unity) ApplyMaterialPassWithCache
    4. 0x00007FF7922F7F95 (Unity) ApplyMaterialPassAndKeywordsWithCache
    5. 0x00007FF791A8FEA4 (Unity) BatchRenderer::ApplyShaderPass
    6. 0x00007FF7919A3C3E (Unity) RenderCasters
    7. 0x00007FF7919AB1FE (Unity) ShadowMapJob
    8. 0x00007FF790DADC93 (Unity) GfxDevice::ExecuteAsync
    9. 0x00007FF7919A6D71 (Unity) RenderShadowMaps
    10. 0x00007FF791A8283D (Unity) RenderLightDeferred
    11. 0x00007FF791A8342C (Unity) DeferredRenderLoop::RenderLighting
    12. 0x00007FF791A7C1D2 (Unity) DoDeferredRenderLoop
    13. 0x00007FF791A7D1E8 (Unity) DoRenderLoop
    14. 0x00007FF791A2618F (Unity) Camera::DoRender
    15. 0x00007FF790C6175D (Unity) Camera::RenderEditorCamera
    16. 0x00007FF790C61953 (Unity) Camera::RenderEditorCamera
    17. 0x00007FF7915859F8 (Unity) Handles_CUSTOM_Internal_DrawCameraWithGrid
  4. ScaryRobotGames


    May 2, 2007
    Thanks for the input mkgame. But I'm afraid I didn't get too much information from the logs. There was a crash.dmp and an error.log file. No editor.log. Here's the starting contents of the error.log file:

    Then a bunch of machine language and then this at the end:
    Not much that I can discern in terms of the code/plugin that's causing the crash.

    The crash.dmp file states: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.